Enlever les caractères spéciaux dans la sortie de npm install

Salut la zone,

Dans mon pipeline de build, j’ai à un moment npm qui installe des packages. Et ça me fait des erreurs qui n’en sont pas dans ma console :

Executing task: Npm-Install
Using addin: Cake.Npm v0.0.0.0 ([NULL])
npm arguments: install --loglevel error
> cwebp-bin@5.0.0 postinstall e:\vsts\c\403\s\src\CCCS\node_modules\cwebp-bin
> node lib/install.js
##[error] √ cwebp pre-build test passed successfully
> gifsicle@4.0.1 postinstall e:\vsts\c\403\s\src\CCCS\node_modules\gifsicle
> node lib/install.js
##[error] √ gifsicle pre-build test passed successfully
> mozjpeg@6.0.1 postinstall e:\vsts\c\403\s\src\CCCS\node_modules\mozjpeg
> node lib/install.js
##[error] √ mozjpeg pre-build test passed successfully
> optipng-bin@5.1.0 postinstall e:\vsts\c\403\s\src\CCCS\node_modules\optipng-bin
> node lib/install.js
##[error] √ optipng pre-build test passed successfully
> pngquant-bin@5.0.2 postinstall e:\vsts\c\403\s\src\CCCS\node_modules\pngquant-bin
> node lib/install.js
##[error] √ pngquant pre-build test passed successfully

Et je pense que ça vient du fait que normalement ça devrait afficher ça:
✓ cwebp pre-build test passed successfully
Sauf que Windows a du mal avec l’unicode j’imagine.
Ma question est donc : est-il possible de désactiver ce caractère spécial avec une option dans npm install ? Jusqu’à présent je n’ai rien trouvé de concluant, mais j’avoue être loin d’être à l’aise avec npm.

Merci

En attendant tu as essayé en lançant ton npm d’un git bash ?

edit: vu sur Stack overflow
cmd /k chcp 65001, pour avoir la gestion de l’unicode, et tu lances npm sur ce shell windows.

edit2: lien github d’où je suis parti. Il faut aussi peut-être changer la police du shell pour la police “Déjà Vu”.

1 Like

Je regarde tout ça, merci :slight_smile:

1 Like

et sinon en mode #GZ, est ce qe tu aurais pas avantage a lancer ta commande depuis un soussysteme linux ?

1 Like

Malheureusement, je n’ai pas le choix de l’exécuteur :frowning: