Erreur d'importation pygame pour python

Bonjour à tous,

j’ai installé pygame pour python sur MAC et lors de l’importation il me renvois cette erreur, si quelqu’un peut m’aider ce serait très gentil merci :

import pygame
Traceback (most recent call last):
File « <pyshell#42> », line 1, in
import pygame
File « /Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/pygame/init.py », line 81, in
from pygame.base import * # pylint: disable=wildcard-import; lgtm[py/polluting-import]
ImportError: dlopen(/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/pygame/base.cpython-39-darwin.so, 2): Library not loaded: /System/Library/Frameworks/Metal.framework/Versions/A/Metal
Referenced from: /Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/pygame/base.cpython-39-darwin.so
Reason: image not found

Salut

Comment as tu installer pygame ? Avec pip ?
Pip est il a jour?
As tu bien paramétré ton virtualenv ?

Salut,

Oui pour les deux premières questions:

Requirement already satisfied: pip in /Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages (20.3.3)

Requirement already satisfied: pygame in /Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages (2.0.1)

non pour la dernière. je vais peut être chercher par la alors.

ok , j’ai installé virtualenv mais
toujours la même erreur en important pygame:

pip list
Package Version


appdirs 1.4.4
astroid 2.4.2
certifi 2020.12.5
chardet 4.0.0
colorclass 2.2.0
distlib 0.3.1
docopt 0.6.2
filelock 3.0.12
idna 2.10
isort 5.6.4
lazy-object-proxy 1.4.3
mccabe 0.6.1
packaging 20.8
pip 20.3.3
pip-upgrader 1.4.15
pygame 2.0.1
pylint 2.6.0
pyparsing 2.4.7
requests 2.25.1
setuptools 49.2.1
six 1.15.0
terminaltables 3.1.0
toml 0.10.2
urllib3 1.26.2
virtualenv 20.3.1
wrapt 1.12.1