Fichiers .bat (batard?)

Bon voilà. Je cherche le moyen de faire exécuter un fichier .bat au démarrege de Windows 2000. En fait, je voudrais faire une sauvegarde de mes Mails de Outlook à chaque démarrage. J’ai essayé la commande xcopy c:lablabla*.* c:mail*.* , mais çà ne marche pas.
Il me sort: Nombre de paramêtres non valide.
Est-ce parce que la commande est trop longue (car ces fichiers se trouvent 8 sous-répertoires plus loin)?
Je voulais alors essayer de copier directement le répertoire lui même mais je ne connais pas la commande.
Que faire?

[Edité le 13/8/2002 par McRemic]

De nada :slight_smile:

Cà fait plaisir de voir que les problèmes rencontrés au quotidien rendent service aux autres :smiley:

Bah ecoute je te remercie, je viens à l’instant d’avoir le même problème, et grâce à toi je n’ai pas cherché toute la soirée cart je me souvenais de ce thread !!!

Merci tu viens de sauver ma journee de congée de demain !!!

J’ai une bonne nouvelle:j’ai trouvé!!!.

xcopy "C:Documents and SettingsClément RémiLocal SettingsApplication DataIdentities{459D1B58-2706-4DFF-B758-391AD28F7ADC}MicrosoftOutlook Express*." d:savemail.*

Vous me direz, on le savait déjà. Le fait est que cette commande fonctionne quand on la tape dans une fenêtre DOS. (merci gigs pour l’astuce du TAB, çà rend bien service çà :wink: )

Maintenant quand je la fait s’executer depuis un fichier .bat, çà ne marche pas.
Comme le disait Moktar, il doit y avoir un problème de langue, car les ‹ é › sont remplacés par ces put… de ‹ U › à la c… gomme!

Alors au lieu d’éditer le fichier avec le Notepad de Windows, je l’ai édité à partir du DOS!! Ben ouais, je sais, j’aurais du y penser plus tôt.
De cette manière, j’ai corriger le problème en remplaçant les ‹ U › avec les ‹ é › .

Heu… je sais pas si j’ai été très clair mais bon…

En tout cas, maintenant çà marche. Merci les gars :slight_smile:

[Edité le 14/8/2002 par McRemic]

hmmm erreur de ma part, je pensait qu’elle etait activée par defaut sur 2k aussi …

je vous conseille neanmoins de fouiner ce site : http://www.zebulon-fr.com
c’est une mine d’or pour les tips :slight_smile:

Merci Donjohn pour cette information inestimable.

Note: forcément, si l’option n’est pas “activée” …

bon pour l’histoire du tab : ici pour clore definitivement la question

pour la place de commutateur : dans le /? il mettent les commutateur derriere la commande

DONC pour McRemic :
utilise le tips du tab pour avoir le chemin exact du repertoire à copié, comme sa t sur de toi a ce niveau là
ensuite tape xcopy /S lecheminquetuviensdetrouveraveclatechniqueduTAB*.* lechemindedestination

Dis moi gigs, tu pourrais nous faire un chti topo à propos de ton asctuce avec tab ? Ca serait vachement sympat ! :slight_smile:

ouai je me suis aussi un peu emporté … sorry …

:slight_smile:

[Edité le 14/8/2002 par gigs]

dit, gigs, toutes mes excuses. c’est vrai que des fois je parle sans refléchir (qui a dit boulet ?).
au fait, je connaissait pas non plus le TAB, et je ne pense pas, et de loin, etre un dieux du shell.

Encore une fois, ttoutes mes excuses.

Mouais, je viens de tester et on dirait que ça marche mais c’est vachement rarebi quand même …

[Edit: ce n’est peut être rien mais je viens de remarquer un truc :

[quote]J’ai essayé de taper ceci:
xcopy /N C:Docume~1Clémen~1Local~1Applic~1Identi~1{459D1~1Micros~1Outloo~1* .* d:savemail
Il me sort toujours la même erreur.–>Fichier introuvable
En rajoutant des guillemets, c’est pareil.[/quote]
A la fin de la source dans le ‘.’ il y a un espace entre ‘*’ et ‘.’ … il se peut que ça vienne de là, les fichiers introuvables. Essayes donc sans l’espace pour voir]

[Edit2: hop je viens de tester avec ‘* .’ et ça ne marche pas, par contre j’ai fait un autre test dans la source en enlevant '.*’ et on dirait que ça marche aussi bien (copie de tous les fichiers)]

[Edité le 14/8/2002 par Nocmahr]

Tu lit le reste du thread avant de poster ?

cf : [quote]au démarrege de Windows 2000[/quote]donce, pas en intéractif !!
essaye encore ! :wink: [/quote]
t neuneu ou koi pour trouver la commande il teste comment avec ses pieds ??? non en tappant des commandes dans un machin noir avec des caracteres qui s’ecrivent haaa c bien oui … dc TAB fonctionne pour tester, apres une fois ke la commande est ok il en fait ce k’il veut !!! interactif ou pas …

et le TAB tt le monde ne connait pas mais excuse moi au gd dieu du shell!!!

J’m’ennerve pas, j’m’explique! :slight_smile:

[Edité le 14/8/2002 par gigs]

Oui c’est clair mais en fait je suis un grand optimiste et je ne pensais pas qu’il n’avait pas jetté un oeil à l’aide en ligne avant de poser la question. Mais bon, maintenant qu’il sait et qu’en plus il a une alternative au script de commande il n’y a plus de soucis. :slight_smile:

Par contre, pour le coup du tab … sous linux ça permet de compléter la commande en cours ou d’afficher toutes les commandes commençant par ce qu’on a déjà saisis mais sous Win2k je ne savais aps … je viens de tester et à part faire des tabulations ça ne fait pas grand chose, pourrait tu donc expliquer un peu mieux cette histoire s’il te plaît ?

[quote]il faut saisir : xcopy “chemin source” “chemin destination” [divers commutateurs]

et non pas xcopy [commutateur] “chem. src.” “chem. dest.”

pas étonnant qu’il ne trouve pas le fichier “/N” ^^[/quote]naaaaaaaan, les commutateurs se placent aussi derriere le xcopy ou tt autre commande DOS), donc c po sa…(teste tu verras :))

[quote]de plus gmargaro propose une alternative interessante (je trouve) qui consiste (si j’ai bien compris) à dire à Outlook Express d’enregistrer les e-mails en lieu sûr genre une autre partition[/quote]ouais, engros tu change simplement le repertoire ou les mails sont stockes. Cela permet de formater le c: sans se soucier des emails, a chaque reinstall de Windows (enfin Outlook mais c la meme chose ;)) tu remet le chemin du rep sur l’autre partition pour retrouver ts tes mails.
par contre sa donne pas la solution pour un stockage de sauvegarde

mais c 'est vraiment bizarre que "xcopy /N C:Docume~1Clémen~1Local~1Applic~1Identi~1{459D1~1Micros~1Outloo~1* .* d:savemail " ne marche pas…
ta essaye avec les noms longs mais sans “” ??? avec exactement la meme syntaxe sauf pour la source evidemment ???

Tu lit le reste du thread avant de poster ?

cf : [quote]au démarrege de Windows 2000[/quote]donce, pas en intéractif !!
essaye encore ! :slight_smile:

[quote]Tu sous-entend quelque chose de particulier qui peut faire avancer McRemic ou bien tu postes comme ça juste pour le fun ?

En espérant qu’il s’agisse de la première option, sous quel OS (quel windows quoi) veux tu éxecuter cette commande ? (même si les différences sont relatviement minimes)[/quote]
Avec une etude de l’aide la question n’aurait pas eu lieu d’etre !
D’autre part avec des os evolués (kernel nt5+) la touche TAB permet un defilement des fichiers/repertoires contenus ds les rep courant pratique pour les noms à ralonge.

Casseur de bloc, Le

Outlook Express n’a effectivement pas de fonction d’archivage moi je parlais d’Outlook .| et te suggérais (subtilement) de passer à Outook ou à un gestionaire de courrier électronique … comment dire … mieux.

[quote]J’ai essayé de taper ceci:
xcopy /N C:Docume~1Clémen~1Local~1Applic~1Identi~1{459D1~1Micros~1Outloo~1* .* d:savemail
Il me sort toujours la même erreur.–>Fichier introuvable
En rajoutant des guillemets, c’est pareil.[/quote]
Oui, non, mais là c’est de l’abus quand même y a des geeks ici qui ont la gentillesse de te rappeler que tu peux obtenir une aide instantanée en ajoutant le commutateur /? après la commande alors tu pourrais faire un effort quand même … non ? :slight_smile:
il faut saisir : xcopy « chemin source » « chemin destination » [divers commutateurs]

et non pas xcopy [commutateur] « chem. src. » « chem. dest. »

pas étonnant qu’il ne trouve pas le fichier « /N » ^^

jettes un oeil ici : http://darkcoderz.free.fr/storage/xcopy.html

[Edit: c juste un c/c de la réponse de xcopy quand on lui passe /? comme argument

de plus gmargaro propose une alternative interessante (je trouve) qui consiste (si j’ai bien compris) à dire à Outlook Express d’enregistrer les e-mails en lieu sûr genre une autre partition]

[Edité le 14/8/2002 par Nocmahr]

A mon avis McRemic t’as un pb de langue… ce n’est pas normal que le shell te change les accents…