Je parie que vous arriverez pas à m'aider

Mode ma vie ON :
J’a la freebox branché sur une carte ethernet sur mon serveur, ensuite le serveur a une seconde carte ethernet qui va vers mon switch. Hop ca marche j’ai la connection.
Je branche mon PC principal sur ce même switch et le tout en DHCP et hop ca marche j’ai le net.
Je branche mon protable et hop ca marche.
Un pot arrive et hop… ca marche pas…
Mode ma vie OFF

J’ai 3 câbles réseau : A, B et C
J’ai donc 3 Pcs chez moi en ce moment : PC1, PC2 et PC3.
Et donc le switch !

Si je branche :
PC1 sur A : OK
PC2 sur B : OK
PC3 sur C : PAS OK !!!

Bien je me dit mon câble est pourri je fais donc :
PC1 sur C : OK
Mmm donc le câble n’est pas pourri… On va rerester autrement :
PC1 sur A : OK
PC1 sur B : OK
PC1 sur C : OK
La suite :
PC2 sur A : pas OK
PC2 sur B : OK
PC2 sur C : pas OK
PC3 sur A : PAS OK !!!
PC3 sur B : OK !!!
PC3 sur C : PAS OK !!!
Bon a part un gourou qq’un à une solution ? Parce qu’avec tout ca je n’arrive pas à brancher les 3…
J’ai éteint mon serveur, débrancher le switch, rebranché le switch et testé le réseau sans le serveur c’est pareil…
Le seul cable qui marche sur tous les ordis est donc le B, A n’aime que PC1 et C pareil…
HELP… j’ose pas taper ça sur google… d’ailleurs je voie pas quoi taper à part : lutin+ethernet+AUSECOURS !
Merci de votre aide… MERCIIiiiiiii !!!

Celui qui me résout le problème je lui élève une statue de 150 mètres de haut sur la place du Capitole à Toulouse !!!

EDIT : putain sont forts les étudiants ici ils me cassent mon énoncé bon … le copier-coller c’est mal je corrige !

Ce message a été édité par Haaz le 22/10/2004

Ben
PC1 sur A
PC3 sur B
PC2 sur C

Quoi ? j’ai dis une connerie ?

ca semble tellement evident qu’il a du faire une erreur dans son enoncé

edit … grillé

Ce message a été édité par DrDrakeRamore le 22/10/2004

L’énoncé est corrigée effectivement il y avait un piège…

Par contre ca choque personne qu’un câble marche ou pas en fonction du PC ?

Ce message a été édité par Haaz le 22/10/2004

essaye en achetant un nouveau cable pour remplacer le A et le C… ils semblent capricieux…
ca vaut pas super cher hein

Hahaha je l’attendais celle la merci de ta réponse et donc dans la matinée mon pot a pris le cable… D !!! Yeeeeee et PC3 sur D nous donne… que dalle !!!

Screeuuuugneuuugneuuu !

Et si cétait le switch ? ou les chinois du FBI ?

Y a un gros fort en réseau là ? non parce que moi pas comprendre… ca a des affinités les câbles ?
Personnellement, hier soir, je passais pour un incompétent moi sous le bureau avec mes câbles là… C’est quoi qui fait que les diodes s’allument ? la carte envoie un signal ? le switch ?

Euh … Tu t’achète un routeur Wifi , comme ça t’a plus besoin de cables ?

Mouaih , bon , je sors .

Tu as droit à combien d’adresses IP avec la Freebox? Vous pouvez avoir autant de PC connectés que vous voulez ou vous êtes limités à 4?

Je demande ça parce que j’ai un problème un peu du même genre.
En fait mon FAI (connection cablo-modem) nous offre la possibilité de se connecter avec 4 ordinateurs maximum (donc ils nous offrent 4 adresses DHCP).

Le problème c’est que leur modem pourri réserve des adresses IP pour chacune des MAC adress trouvées sur le réseau. Problème : le switch a une adresse IP, donc 4 adresses sont réservées : pour 3 PC et une pour le switch. Du coup impossible de connecter 4 ordinateurs.

Peut-être que c’est un problème similaire?

Merci pour ta réponse mais de mon côté je ne demande qu’une adresse, c’est mon serveur chez moi qui attribue en dhcp des adresses à mes petits pcs.

Entre midi et 14h j’ai retenté des branchement mais rien a signalé… ca me tue quand même qu’un câble puisse marcher en fonction du pc… j’en avait jamais entendu parler…

Bon je vais proposer qulques idées de test.

Bon, t’es câbles, ceux sont tous des droits?
Les cartes réseaux? Tu es sûr de leur qualité?
Il existe autrement un problème rarissime mais que j’ai vu une fois tout de même: et sil est cartes réseaux avaient la même adresse mac? Ne me dites pas que c’est impossible, comme je l’ai déjà dit, j’ai déjà vu le cas.
La configuration de tes ordi est-elle bonne? (adresse ip en dynamique etc etc)
Pas de firewall qui traine?

Fais attention aussi, sur certains modèles de switch ou hub, certains ports sont réservés pour le montage en série, sans que ce soit forcément indiqué… (du coup j’ai pris l’habiture de réfléchir en terme de nb de ports - 1 dès que je me procure un switch ou hub).

Au pire, vire le dhcp et met des adresse fixes en spéficiant bien la paserelle par défaut…

[quote]Au pire, vire le dhcp et met des adresse fixes en spéficiant bien la paserelle par défaut…[/quote]je te dirais bien de tenter ça aussi… ca peut t’aider à voir précisement où ça chie…

undefined

EDIT : je disais que tous mes câbles sont des câbles croisés (Heuuu droit… Heu voila tu me mets le doute… ca se vérifie facilement ca non ? c’est écrit sur le câble) mais bon ca m’explique pas pourquoi parfois ca marche et parfois non en fonction du câble et de l’ordi.

La conf des différentes machines n’y est malheureusement pour rien (vu que serveur éteint j’ai les mêmes symptomes).

Je pensais prendre chaque câble et me faire certifer qu’ils fonctionnaient mais comment faire cela ?

Ce message a été édité par Haaz le 22/10/2004

Faut prendre un testeur de cable RJ45. J’ai pas trouve “tout seul” sur ldlc mais ca doit exister.

LoneWolf
Info en 1 ligne. Classe.

Perso, je ferais le bourrin:
test des 3 cartes successivement sur le PC1, qui a l’air de marcher, en fixant a la main les adresses.
Si les 3 cartes marches sur les 3 cables, au moins, tu seras sûr de ton matos…

edit:
ah ouais.
pas vu qu’il y avait un portable.

Et sinon, en réseau tout bete, avec ces cables, elles se pinguent (ouh la, vive la conjugaison improvisatoire) les uns les autres, tes machines ?


Ce message a été édité par TeK le 22/10/2004

Ca doit être un problème de cables croisés, a mon avis.
Normalement, te faut des cables droits, pour brancher un PC a un switch. Le fait est que tu dois avoir une carte réseau sur un des PCs qui “recroise” pour que ca marche quand même.
Solution la plus simple, trouver des cables droits

[quote]Ca doit être un problème de cables croisés, a mon avis.
Normalement, te faut des cables droits, pour brancher un PC a un switch. Le fait est que tu dois avoir une carte réseau sur un des PCs qui “recroise” pour que ca marche quand même.
Solution la plus simple, trouver des cables droits [/quote]j’y avais pensé l’espace d’un moment mais c’est pas possible vu qu’un des pc marche sur tout les cables… si c’était le cas, il ne devrait marcher qu’avec les cables sur lesquels les autres pcs ne marchent pas… non ?

D’accord avec ton raisonnement, si PC1 sur C est Ok, mais que PC3 sur C non, donc C n’est pas en cause ( ou alors la panne est aléatoire, mais avec un cable ??? )

J’ai des questions débiles:

  • par “pas OK” on entend quoi ? Ca pingue pas ? Les leds du switch (ou est ce un hub) ne fonctionnent pas ?
  • par “Ok” on entend quoi ? Ca pingue ? Les leds du switch s’allument ?
  • a tu changer les branchement coté switch également pour voir si ce n’était pas un des ports du switch qui déconne

Vérifie déjà que sur les n ports de ton hub s’il n’y a pas une entrée croisée (en générale c’est sois la première soit la dernière).

Vérifie que tes cables sont droits. Un cable croisé en général la tête de prise est de couleur différente par rapport au cable.

On m’a dit un jour que certaines cartes réseaux sont capable de corriger automatiquement le fait que le cable est croisé ou non… Ce qui pourrait expliquer que A marche partout.

Première hypothèse:A et C sont croisés (soit du fait du cable, soit du switch).

[quote]Vérifie que tes cables sont droits. Un cable croisé en général la tête de prise est de couleur différente par rapport au cable.[/quote]Et puis sinon, il suffit de regarder les prises:
si les fils sont dans le même ordre, c’est un droit, sinon, c’est un croisé.

edit:
j’ai trouvé des photos !

http://membres.lycos.fr/tekrotzen/cafzone_…cable_droit.jpg

http://membres.lycos.fr/tekrotzen/cafzone_…able_croise.jpg

PS: sinon, j’aime bien ton idée de carte réseau qui corrige les cables.
ça me plait, je trouve ça classe, comme solution à l’énigme.

Ce message a été édité par TeK le 23/10/2004