Les Newsgroups pour les Nuls - Saison 2 : Sonarr, NZBGet & Couchpotato


#201

Bam, en week-end loin de mon PC : flash of insight ! Le problème pourrait bien provenir du firewall Windows. Je regarde ça dès mon retour.


#202

Sinon vous utilisez un plugin genre nzbget-chrome :slight_smile:


#203

Il marche pas avec la MAJ de nzb.su pour l’instant…


#204

Oui précisément et on ne peut plus utiliser localhost ni les ip LAN. Tout est maintenant relatif au serveur nzb.su.


#205

Bon, pas mieux en ajoutant NZBGet à la whitelist du firewall Windows. La Box de Numericable a l’air bien naze pour configurer du port forwarding…


#206

Ca je te confirme, personnellement en plus elle reboot à chaque ajout d’un nouveau port. Du coup je l’ai bridgée (très salement) et j’ai mis un vrai routeur, c’est beaucoup plus agréable à utiliser. Mais cela dit, une fois que c’est fait, ça fonctionne, et ta redirection est bien correcte.

Au niveau du firewall Windows, si tu as ajouté l’application nzbGet ça ne suffit pas, à mon avis il faut carrément ouvrir le port 6789.


#207

Nope, pareil en ouvrant le port 6789 en TCP+UDP pour toutes les applis dans le firewall Windows.

Cela dit, je ne vois rien dans les logs de La Box, c’est à se demander si la requête va jusqu’à elle. Après, je ne connais pas le niveau de verbosité du bouzin.


#208

Là je t’avoue je sèche. Sur ton screenshot, ta redirection est bonne. Si les ports sont ouverts sur les pares-feu et que l’adresse publique est OK, tu devrais logiquement pouvoir voir ton nzbGet quand tu tapes http://adresseip:6789


#209

Vérifie si ton nzbget écoute sur “localhost” ou sur ta vraie IP interne: s’il est sur localhost les flux redirigés n’iront pas jusqu’à lui:

Les 2 notes du champ ControlIP vous avertissent: si tu mets 0.0.0.0 il écoutera en pratique sur 127.0.0.1 (localhost), et donc ne sera pas joignable de l’extérieur (ou même d’une autre machine chez toi)

Edit: je dis des bétises, le passage de 0.0.0.0 à 127.0.0.1 c’est qu’en mode client, pas de souci sur le mode serveur


#210

Bon je te rassure, j’ai le même problème d’accès externe: j’ai la box NC en bridge et je gère donc les ports sur mon routeur (R7000) et ça ne marche pas mieux…

Putain, j’ai eu un éclair d’espoir mais non, de mon côté c’est bien configuré sur l’IP locale :frowning:


#211

Mon NZBGet écoute sur 0.0.0.0, ce qui correspond normalement à écouter sur toutes les adresses.

Au départ, j’avais NZBGet sur mon HTPC et je lançais le navigateur depuis mon PC principal, je confirme que 0.0.0.0 me permettait d’y accéder alors que 127.0.0.1 limitait l’utilisation du client au HTPC.


#212

Du coup je commencerais par regarder 2 autres choses:

  • Ouvre un cmd ou un powershell, tape netstat -anb et regarde sur quelles IP tu vois nzbget en écoute sur le port 6789
  • Utilise un soft genre Microsoft Message Analyzer ou Wireshark pour sniffer le trafic réseau qui arrive sur ton PC et voir si la box redirige bien quelque chose

#213

Je rajoute un petit telnet ippublique 6789 qui peut parfois apporter des infos utiles via son message d’erreur


#214

Oui j’avais pensé à Wireshark. Je regarderai ça. Merci en tout cas :slightly_smiling_face:

telnet ? Ca existe encore ça ? :stuck_out_tongue_winking_eye:


#215

Putain ça marche. J’ai rien capté. L’interface n’était pas accessible depuis mes navigateurs en http://public_ip:6789. J’ai testé depuis mon iPhone en 4G. Connexion ! J’essaie sur l’iPhone en wifi. Pareil ! Je reviens sur les navigateurs du PC (Firefox/Chrome) : ça marche !!!

Pour résumer, indépendamment du fait que le pourquoi du comment c’est tombé en marche me dépasse, il faut :

  • écouter en 0.0.0.0 sur NZBGet
  • rediriger le port 6789 en TCP sur l’IP locale du PC dans l’admin de la box
  • ouvrir le port 6789 en TCP pour le programme NZBGet dans le firewall Windows

Encore merci à vous tous pour votre aide.


#216

Bonjour,

Merci pour le tuto, mais… rien ne se passe. Couch installé, NZBGet installé, le tout connecté ensemble, configuré avec mon abo. news, et impossible de DL.

Quelqu’un peut-il me dire simplement comment lancer un DL ???

J’ai testé avec 2 films dans couch, ajoutés à la wanted list, et … Rien.


#217

la question est : est-ce que si tu recherches à la main sur ton newsgroup , tu trouves ?
Si oui => t’as une coquille dans une conf ( vérifie les logs de couchpotato qu’il recherche bien dasn ton Ng, et qu’il trouve bien ce que tu recherches )
Si non => t’as une coquille dans ce que tu recherches :slight_smile:


#218

Merci pour ta réponse. En fait, j’ai installé tout ça pour éviter d’aller fouiller dans le NG qui est un bordel innommable (par grab it).
Je débute, et je n’arrive pas à comprendre à quoi sert NBZGet, vu qu’il n’y a absolument rien dans l’interface web et qu’il m’est impossible d’ajouter quoi que ce soit…


#219

NZBGet sert au téléchargement, comme Grabit, mais il n’indexe rien. Je ne te vois pas parler d’indexeur, le problème peut-il venir de là ?


#220

Euh… aucune idée.

Question simple : pourquoi NZBGet et/ou couchpotato ne recherche pas dans mon newsgroup ?
Grab-it y arrive, lui. Sauf que c’est inbitable et inexploitable.