[LibreElec] [Résolu] mount CIFS qui ne fonctionne pas

Bonjour,
Je viens de mettre à jour mon LibreElec (sur Raspberry Pi 2). Jusque là, j’utilisais un script (grâce à l’exemple fourni dans les entrailles du /.config/system.d que suit pour monter les dossier de mon nas dans /storage/nas1 (je sais KODI gère le smb, mais j’ai besoin de ça pour des trucs comme sickbeard ou couchpotato) :
"
[Unit]
Description=test cifs mount script
Requires=network-online.service
After=network-online.service
Before=kodi.service

[Mount]

What=//192.168.1.5/Volume_1
Where=/storage/nas1
Options=username=mouz,password=motdepassedemouz,rw
Type=cifs

[Install]
WantedBy=multi-user.target
"
Puis j’applique les conseils suivant :
Important:
this file must be renamed to .mount where , is the FULL path
where the share will be mounted but slashes “/” MUST BE REPLACED with dashes “-” with .mount
as extension.
This means, if we want mount to “/storage/nas1” (see above “Where=/storage/nas”)
then this file must be renamed to ‘storage-nas1.mount’ and can be enabled via ssh with the
command ‘systemctl enable storage-nas1.mount’

Ce qui fonctionnait très bien, mais depuis la réinstallation, le dossier se créé bien, mais reste vide. La configuration de mon Nas n’a pas changé, les autorisations de lecture/écriture n’ont pas changées…

Bref, je sèche, et ça m’agace. Qu’est ce que je rate ? Y aurait-il une bonne âme pour me filer un coup de main s’il vous plait ?

Tu as essayé un mount à la main ? (en ligne de commande)

Essaie de remplacer cette ligne par :

Options=username=mouz,password=motdepassedemouz,rw,vers=2.1

voire

Options=username=mouz,password=motdepassedemouz,rw,vers=1.0

Pour forcer la compatibilité avec les anciennes versions de samba

Oui, ca me répond que l’hote n’est pas joignable, alors qu’il le ping sans problème, et je peux y accéder via Kodi.

Haaaaannnn, j’avais pas pensé à la version samba… je vais vérifier sur mon NAS et j’essaye ça. Merci

Merci, c’était ça, mon Nas ne supporte que le samba v1.0 alors que la nouvelle version de Libreelec est configuré par défaut pour 2 et 3.
J’ai du régler la version minimale de Samba dans les config LibreElec et ajouter “vers=1.0”

à ma ligne de script comme tu m’a conseillé, et là ça fonctionne.

Merci à tout les deux, je n’y aurai pas pensé.

2 « J'aime »