Petit problème avec xinetd

Bonjour!

Je me suis lancé (pour la première fois) dans la configuration du lancement d’un démon via xinetd.

Le programme que je veux lancer est MLdonkey.

J’aimerai qu’il se lance quand je me connecte via l’interface distante Sancho, sur le port 4001.
Donc pour lancer le core MLdonkey sur le serveur, il me suffirait de lancer Sancho sur mon PC distant.
Pour l’arrêter, il me suffirait de cliquer sur “kill core” dans Sancho.

J’ai donc fouillé dans les pages de man (man 5 xinetd.conf) pour écrire mon fichier de conf xinetd pour MLdonkey, qui est /etc/xinetd.d/mldonkey.
Voici son contenu:[quote]service mldonkey
{
instances = 1
socket_type = stream
protocol = tcp
user = mldonkey
group = mldonkey
server = /usr/bin/mlnet
wait = yes
port = 4001
only_from = 192.168.0.0/24
}[/quote]

/etc/xinetd.conf est resté d’origine:[quote]# Simple configuration file for xinetd

Some defaults, and include /etc/xinetd.d/

defaults
{

Please note that you need a log_type line to be able to use log_on_success

and log_on_failure. The default is the following :

log_type = SYSLOG daemon info

}

includedir /etc/xinetd.d[/quote]

cat /var/log/daemon.log me renvoie, au moment du lancement de xinetd:[quote]Aug 4 12:02:17 synapse xinetd[19664]: Reading included configuration file: /etc/xinetd.d/chargen [file=/etc/xinetd.conf] [line=14]
Aug 4 12:02:17 synapse xinetd[19664]: Reading included configuration file: /etc/xinetd.d/daytime [file=/etc/xinetd.d/daytime] [line=28]
Aug 4 12:02:17 synapse xinetd[19664]: Reading included configuration file: /etc/xinetd.d/discard [file=/etc/xinetd.d/discard] [line=26]
Aug 4 12:02:17 synapse xinetd[19664]: Reading included configuration file: /etc/xinetd.d/echo [file=/etc/xinetd.d/echo] [line=25]
Aug 4 12:02:17 synapse xinetd[19664]: Reading included configuration file: /etc/xinetd.d/mldonkey [file=/etc/xinetd.d/mldonkey] [line=26]
Aug 4 12:02:17 synapse xinetd[19664]: Reading included configuration file: /etc/xinetd.d/time [file=/etc/xinetd.d/time] [line=13]
Aug 4 12:02:17 synapse xinetd[19664]: removing chargen
Aug 4 12:02:17 synapse xinetd[19664]: removing chargen
Aug 4 12:02:17 synapse xinetd[19664]: removing daytime
Aug 4 12:02:17 synapse xinetd[19664]: removing daytime
Aug 4 12:02:17 synapse xinetd[19664]: removing discard
Aug 4 12:02:17 synapse xinetd[19664]: removing discard
Aug 4 12:02:17 synapse xinetd[19664]: removing echo
Aug 4 12:02:17 synapse xinetd[19664]: removing echo
Aug 4 12:02:17 synapse xinetd[19664]: removing time
Aug 4 12:02:17 synapse xinetd[19664]: removing time
Aug 4 12:02:17 synapse xinetd[19664]: service/protocol combination not in /etc/services: mldonkey/tcp
Aug 4 12:02:17 synapse xinetd[19664]: xinetd Version 2.3.14 started with libwrap loadavg options compiled in.
Aug 4 12:02:17 synapse xinetd[19664]: Started working: 0 available services[/quote]

Je lance Sancho, qui tente d’effectuer une connexion TCP sur le port 4001, mais MLdonkey n’est pas lancé par xinetd.
J’ai donc dû commettre une erreur quelque part, mais où?

Merci de votre aide, bye!

Meuh non, c’est juste que tu sais pas lire l’anglais

Ho mince, il me dit pourquoi ca marche pas
Je vais vite regler ca:

Et voila!

LoneWolf
La lecture des logs, c’est trop dur B)

Et MLDonkey c’est mal

Oooops, désolé, je n’avais pas fait attention B)

ColdFire > pourquoi MLdonkey c’est mal? Je le trouve très bien au contraire, il me permet de centraliser mes téléchargements de torrents, téléchargements http/ftp, et d’autres, ce qui est fort pratique je trouve.

Ca ne fonctionne toujours pas.

Mon fichier de conf:[quote]service mldonkey
{
instances = 1
socket_type = stream
protocol = tcp
user = mldonkey
group = mldonkey
server = /usr/bin/mlnet
wait = yes
port = 4001
cps = 100 10
only_from = 192.168.0.0/24
}[/quote]
cat /var/log/daemon.log renvoie:[quote]Aug 4 13:27:50 synapse xinetd[9059]: Reading included configuration file: /etc/xinetd.d/chargen [file=/etc/xinetd.conf] [line=14]
Aug 4 13:27:50 synapse xinetd[9059]: Reading included configuration file: /etc/xinetd.d/daytime [file=/etc/xinetd.d/daytime] [line=28]
Aug 4 13:27:50 synapse xinetd[9059]: Reading included configuration file: /etc/xinetd.d/discard [file=/etc/xinetd.d/discard] [line=26]
Aug 4 13:27:50 synapse xinetd[9059]: Reading included configuration file: /etc/xinetd.d/echo [file=/etc/xinetd.d/echo] [line=25]
Aug 4 13:27:50 synapse xinetd[9059]: Reading included configuration file: /etc/xinetd.d/mldonkey [file=/etc/xinetd.d/mldonkey] [line=26]
Aug 4 13:27:50 synapse xinetd[9059]: Reading included configuration file: /etc/xinetd.d/time [file=/etc/xinetd.d/time] [line=14]
Aug 4 13:27:50 synapse xinetd[9059]: removing chargen
Aug 4 13:27:50 synapse xinetd[9059]: removing chargen
Aug 4 13:27:50 synapse xinetd[9059]: removing daytime
Aug 4 13:27:50 synapse xinetd[9059]: removing daytime
Aug 4 13:27:50 synapse xinetd[9059]: removing discard
Aug 4 13:27:50 synapse xinetd[9059]: removing discard
Aug 4 13:27:50 synapse xinetd[9059]: removing echo
Aug 4 13:27:50 synapse xinetd[9059]: removing echo
Aug 4 13:27:50 synapse xinetd[9059]: removing time
Aug 4 13:27:50 synapse xinetd[9059]: removing time
Aug 4 13:27:50 synapse xinetd[9059]: xinetd Version 2.3.14 started with libwrap loadavg options compiled in.
Aug 4 13:27:50 synapse xinetd[9059]: Started working: 1 available service[/quote]
Et lorsque j’essaie de me connecter aucun nouveau message n’apparaît dans le log, mais la connexion est refusée.

Si je vire le “only_from = 192.168.0.0/24”, et que je tente de me connecter, dans le log j’obtiens:[quote][…][Aug 4 13:26:50 synapse xinetd[9008]: warning: can’t get client address: Transport endpoint is not connected[…][/quote]environ des centaines de fois. Et ça ne se connecte pas.

J’ai ajouté dans mon fichier de conf: "cps = 100 10"
Ce paramètre est temporaire, il autorise 100 connexions par secondes sur le port 4001, et si ce quota est dépassé, il ne répond plus pendant 10s.
J’ai été forcé de mettre ce paramètre, sans quoi il me disait dans le log qu’il y avait trop de connexions par secondes (plus de 20).

Donc voilà, je ne sais pas trop comment faire en fait, peut être que ce n’est pas possible avec MLdonkey pour je ne sais quelle raison?