Problème de formulaire HTML/PHP hyper basique

Hello la zone !

J’aimerais me faire un script tout con qui utilise de l’html et du php et je n’arrive pas à voir où ça merde.
Ce que je veux faire : mettre une URL dans le formulaire “adresse”, quand j’appuie sur “valider”, la variable adresse (l’URL donc) vient s’écrire en bas, en clair (donc pas en code) pour que je n’ai qu’à recopier le code pour l’utiliser après. Fact : ça ne marche pas, la variable “adresse” ne s’affiche jamais, j’ai du blanc à la place.

Bonus : j’aimerais pouvoir faire une autre variable qui répond au même “valider” pour remplacer “NOMDUSITE” par ce que je veux. Pouvez-vous m’éclairer ?

[html]

Lazynator v1.0

Lazynator v1.0

<a href="<?php echo $_POST['adresse']; ?>" target="_blank">NOMDUSITE</a>

</body>
[/html]

Bah ton code est bon, t’aurais pas un souci d’environnement plutôt ? ton fichier est bien nommé lazynator.php ?

Oui, c’est correctement nommé, j’ai même tenté avec 2 pages php, une source et une cible et rien à faire, ça n’affiche pas ce qu’il y a dans le form. J’ai écrit ça vite fait avec notepad++ et je l’ouvre avec Chrome, mais je ne sais pas si ça a un grand impact.

Non aucun, mais c’est zarb.

Tu l’ouvres dans ton browser… en local ? il te faut un host avec PHP quand même. :wink:

OH PAS CON. Ca doit être ça. Merci :x.

Edit : uploadé sur le serveur, ça fonctionne. Putain, je suis un boulet des fois.

oui donc file:///E:/www/base/lazynator.php
et http://localhost/base/lazynator.php

… c’est pas pareil. :wink:

Si t’es comme je le crois sous osx hésites pas à t’installer un http://www.mamp.info/en/index.html ça dépanne bien :wink:

Je suis sous Windows à la maison, mais je note pour quand je récupérerai le MBA de fonction :).

Wamp sinon pour l’equivalent windows.