[Résolu][HDD][SATA][IDE][WinXP] Ajoutons un disque, et foirons le tout

Bonjour à tous.

J’ai besoin d’aide (bon, on s’en doute).

Voilà, il fut un temps, j’avais un disque dur de 120GB (Windows XP SP2 mitonné aux petits oignons depuis avril 2003) (IDE)… Il commençait à être à l’étroit, alors j’achetai un disque dur de 320 GB (SATA II, mais le 2 on s’en fout).
J’utilise HD Clone pour cloner l’intégralité du petit sur le gros. Puis après Partition Magic, pour réagencer l’espace disque afin de tout utiliser correctement. Je reboote. Au bios, je désactive le disque IDE. Je relance… Tout marche.

En gros j’avais:

[*]C: système [*]D: Applis [*]E: Jeux [*]F: Mes documents et Traitement Video [*]G: (disque externe) Photos [*]H: Download et quelques backups [*]I: je ne sais plus quoi [*]J: SWAP [*]L:;M:,O: partitions sur disques externes

Pendant quelques jours je laisse comme ça (donc IDE désactivé).

Hier (ou avant-hier), je me dis, bon, maintenant que ça tourne (donc tout démarre sur le dd sata), il serait temps de réactivé l’ide. Hop, reboote. Passage dans le bios, réactivation de l’ide…

Et première erreur…

Je boote sous XP. Bien entendu, l’OS se débrouille comme il peut mais mélange ses petits (ah oui, je n’ai pas précisé, mais j’ai en plus deux disques externes en firewire (80 et 120)). Mon C: (donc le Sata) devient D: ou quelque chose comme ça. En gros plein de désordre dans les partitions (n’oublions pas j’ai cloné les partitions), le changement de lettres ne serait pas trop critique. Mais j’ai l’impression que ça a foutu un sacré boxon.

Innocement, j’essaye de changé les lettres, et comme un andouille (enfin ça je l’apprendrais plus tard) j’ai remarqué que l’on ne peut changer la lettre du disque de boot que lorsque l’on est loggé en admin.

Bien entendu, plein de raccourcis ne fonctionnent plus ou plus correctement. Je me dis, je reboote, j’efface les partitions du disque IDE, et ça devrait marcher.

Deuxième erreur…

J’efface les partitions sur le disque IDE, j’en crée 2 à la place des 5 ou 6 que j’avais. Je reboote… J’attends… Et là j’ai un logo: Windows XP avant l’étape de login… Et ça dure, ça ne passe pas…

Après 20 minutes, je reboote, je désactive le disque IDE, je relance XP, ça ne marche pas mieux, toujours attente… Je tente une réparation avec le CD d’XP SP1, il me gonfle pour les drivers, mais bon, ça passe.

Je reboote… Pas mieux…

Mode sans échec… Pas mieux, toujours l’attente au niveau de l’écran juste avant le login (attention, je ne parle pas de l’écran de loading hein)… Hier soir, je me dis: hop, je vais lui laisser toute la nuit, p’têt que j’ai pas attendu assez longtemps.

Ben non, ce matin, pas mieux. Rien… La led du dd clignote une fois de temps à autre, mais c’est tout.

Et là: je crie et je pleure…

Autant je ne pense pas avoir perdu les données… Autant reformater ce n’est pas vraiment une option que j’envisage… Soit cela reste envisageable… Mais ce qui me gonfle, c’est les e-mails. Je suis du genre archiviste et je dois en avoir qui remonte à 1999 (oui, le siècle dernier) (la question n’est pas de juger: qu’est-ce que je peux bien faire d’emails aussi vieux, la question c’est que je veux les récupérer (sous Outlook Express, je précise), et encore plus important, je veux récupérer les comptes emails (sans avoir à les resaisir, reconfigurer les règles et tout le tsouin tsouin).

NB: à ce sujet, ne pas me parler de logiciels libres-gnu-gnu-pinguoin pour les emails, ce n’est absolument pas la question. Je le répète, avant ma bourde, j’avais un système qui fonctionnait, mitonné aux petits oignons et qui n’avait pas un seul problème de sécurité - Merci de votre compréhension.

Donc pour en revenir à Outlook Express, bien entendu, je n’avais pas fait de backup des comptes depuis… Je ne sais même plus quand.

Quand je démarre à partir du CD d’XP, je peux accéder au disque (SATA) en mode console de récupération, a priori, tout est encore là… Par contre, je me prends un peu (voire même beaucoup) la tête pour que l’ordi redémarre correctement… Et à la limite j’aimerai comprendre pourquoi je n’arrive même plus à l’écran de login.

Si vous avez des idées (constructives B) ), merci.

[quote]Edit: euh… oui, pour le coup, Google n’a pas vraiment aidé (à part pour remettre C pour le disque système)…
Edit du 25/01/2007: problème résolu cf voir plus bas.[/quote]

Tu prends un MiniPE (ou autre livecd linux) (oui, je sais tu voulais pas en entendre parler, mais tu as merdé, et ca peut sauver tes fichiers “precieux”), tu recuperes ton fichier mail d’outlook express, avec les regles et comptes (une recherche google te diras ou tout ca est stocké), ou tu installes un truc genre genie outlook backup, et tu reformates, sachant que c’est inutile de faire moults partitions comme tu as fais auparavant, a part multiplier les riques de pertes de données par corruption de la table des partition (et avec partition magic, dieu sait que ca arrive).

Quand on pense qu’un simple ghost t’aurais epargné tout ca.

C’est clair qu’un Ghost (ou tout programme de clonage de partoche) permet de prévenir des bourdes. Bah justement, si j’y avais pensé, je ne serai pas là B).

Quand je dis que je ne veux pas entendre parler de programme libres-gnu-blahblah, c’est surtout pour éviter d’avoir des gus dire que:

J’utilise aussi Thunderbird pour un autre compte d’email, et lui aussi me fout des informations dans la bdr ou dans le dossier “Documents and Settings/user/blabla”.

Partition Magic ne m’a pas foutu le truc en l’air… Je continue de chercher cependant. Merci!

Concernant Outlook Express, tu peux voir le chemin où sont sauvegardés tes mails en allant dans “Outils - Options - Maintenance - Dossier de stockage”. Perso d’ailleurs, je déplace toujours ce dossier de C: pour le mettre sur une autre partition. Pour les règles de courrier et les réglages des comptes c’est autre chose, mais en tout cas tu peux sauvegarder tes fichiers dbx sans trop de problème normalement. Ce sera toujours ça.

Merci Chris.

Oui, c’est aussi le système que je pratique: les mails, My Documents, les *.pst, etc. sont tous dans des partitions différentes de celles du système. Elles sont normalement en lieu sûr et ont été sauvegardées il y a une semaine au plus.

Les règles, et surtout “l’identité” sont dans la base des registres. Il faut juste que je parvienne à les extraire… Je vais y arriver, ça je n’en doute pas. C’est juste une question de temps (sans compter que de l’autre côté j’installe une Debian pour en faire un serveur, sur une vieille machine recyclée, mais OSEF B) ).

Mais je prends toutes les idées, y compris le formatage. Là j’ai quelques pistes, je vais essayer dès que l’autre machine sur laquelle je tape ce post aura fini le gravage.

Merci.

Un up juste pour dire que c’est Résolu.

Alors comment j’ai fait? C’est très simple Marlyse… Beaucoup de bol B)

Mon disque IDE avait été volontairement repartitionné avec Partition Magic, et reformaté aussi, mais n’avait pas été utilisé. J’ai utilisé un logiciel (je n’ai plus en tête) pour faire l’opération inverse, en gros essayer de retrouver les “anciennes” informations. Ca a marché. Donc l’ancien disque dur (IDE) a été réactivé et les fichiers figurant sur la partition système de l’IDE ont été bêtement copiées sur la partition système du SATA (qui avait été cloné à partir de l’IDE).

Et vala. C’est pas la méthode que je recommanderai à tout le monde, mais ça a le mérite de marcher, et je n’ai pas dû tout réinstaller. Du coup je n’ai rien perdu, si ce n’est 1 ou 2 favoris et les historiques (et encore).

Merci à Ana-L pour les pistes.