RESOLU][WORDPRESS] Theme qui ne fonctionne pas

Dans la série “péripeties avec OVH et Wordpress” je demande l’épisode 14!

Après avoir découvert qu’on pouvait installer un module Wordpress avec OVH qui configurait tout automatiquement, je me trouve confronté à un nouveau problème: j’essai d’installer le thême modicus avec lequel je n’avais aucun problème lorsque mon wordpress était hérbergé par Free. Là lorsque je choisi le thême modicus dans mes “Préférences”, j’ai ensuite la phrase suivante qui s’afficher quand je vais sur mon blog:

Je comprend pas…

Pour info voilà le contenu de header.php:

[quote]

> <?php bloginfo('name'); ?> <?php if ( is_single() ) { ?> » Blog Archive <?php } ?> <?php wp_title(); ?>
	<style type="text/css" media="screen">
		@import url( <?php bloginfo('stylesheet_url'); ?> );
	</style>
	
	<link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feed" href="<?php bloginfo('rss2_url'); ?>" />
	<link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
<?php wp_head(); ?>
<a name="top"></a>
<?php bloginfo('name'); ?>
[/quote]

Il faut que j’ajoute quelque chose au niveau de “language attribute()” si j’ai bien compris… Mais quoi?

Alors j’y connais pas grand chose en php mais la tout simplement header.php fait appel a la fonction language_attributes() (2eme ligne) qui n’est definie nulle part visiblement.
Essaie de virer cet appel pour voir , genre en remplacant <html xmlns=“http://www.w3.org/1999/xhtml” <?php language_attributes(); ?>> par

Bah, tu vires le php là et tu mets les attributs en dur

Ce qui doit donner ça au final

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" lang="fr"> et zoup

Merci Hazadess, ça fonctionne après la modif! B) Bon, j’espère voir le bout du tunnel là parce qu’entre le sucrage de compte chez Free et le passage laborieux chez OVH les prises de tête sont nombreuses. B)

Ah bah non, c’est pas fini:
Dans ma sidebar j’ai ça:

J’ai compris ce qui clochait! Le module Wordpress dont je me servais, via OVH, a installé la version 2.0.4 or auparavant je me servais de la version 2.2 (la dernière); le thême modicus utilisé devait être optimisé pour la 2.2 d’où les soucis. Donc après upgrade de wordpress et réinstallation du thême… OUF, ça fonctionne enfin correctement!