[SAMBA][MACOSX] Grosse l33t sur Samba/Mac demandée!

'sieurs dames,
voilà j’ai une machine sous debian 3.0 qui fait office de serveur de fichiers avec Samba (version 3.0.14a-3).
Il y a une gestion des droits de lecture/écriture en fonction des répertoires et des comptes/groupes utilisateurs, ça marche parfaitement avec tous mes postes sous windows, toutes versions. Par contre, les utilisateurs sous Mac ne peuvent rien écrire dessus! Que ce soit avec OS 9 ou X, que la gestion des droits soit activée ou que les vannes soient grandes ouvertes (security = share dans smb.conf), rien à faire! En fait, avec un copy sous la console ça marche, mais avec le finder, rien, nada, il me dit que je n’ai pas les droits. ça fait des mois que j’essaye toutes les suggestions récoltées sur le net pour mon smb.conf, mais rien n’y fait.
Alors en désespoir de cause, car jusqu’à présent je m’étais promis de pas demander de l’aide pour le boulot sur ce site, je vous demande votre aide, frères cafzoniens!
Ha oui, et si je mettais mon smb.conf, ça pourrait aider je pense:

[quote]#======================= Global Settings =======================

[global]
workgroup = LANGROUP
server string = %h server (Samba %v)
; wins support = no
; wins server = w.x.y.z
dns proxy = no
; name resolve order = lmhosts host wins bcast
log file = /var/log/samba/log.%m
max log size = 1000
; syslog only = no
syslog = 0
panic action = /usr/share/samba/panic-action %d

####### Authentication #######

; security = user
encrypt passwords = true
passdb backend = tdbsam guest
obey pam restrictions = yes
; guest account = nobody
invalid users = root
; unix password sync = no
passwd program = /usr/bin/passwd %u
passwd chat = Enter\snew\sUNIX\spassword: %n\n Retype\snew\sUNIX\spassword: %n\n .
; pam password change = no

######## File sharing ########

; preserve case = yes
; short preserve case = yes

############ Misc ############

; include = /home/samba/etc/smb.conf.%m
socket options = TCP_NODELAY
; message command = /bin/sh -c ‘/usr/bin/linpopup “%f” “%m” %s; rm %s’ &
; domain master = auto
; idmap uid = 10000-20000
; idmap gid = 10000-20000
; template shell = /bin/bash

Charsets

unix charset = 850

#======================= Share Definitions =======================

[homes]
comment = Home Directories
browseable = no
writable = yes
create mask = 0700
directory mask = 0700
veto files = /._/.AppleD/Network Trash Folder/TheFindByContentFolder/TheVolumeSettingsFolder/Icon*/$
delete veto files = yes
;oplocks = no
veto oplock files = /.xls/.mdb/.ldb/.doc

[commun]
path = /mnt/disque160/commun
browseable = no
writable = yes
force create mode = 2775
directory mode = 2775
veto files = /._/.AppleD/Network Trash Folder/TheFindByContentFolder/TheVolumeSettingsFolder/Icon*/TemporaryItems/:AFP_AfpInfo:$DATA/:AFP_Resource:$D$rce:$DATA/
delete veto files = yes
;oplocks = no
veto oplock files = /.xls/.mdb/.ldb/.doc[/quote]

Chez moi j’ai du samba sur un server FreeBSD, ca passe nikel sous OSX (windows et linusque).
A priori il me semble que j’ai rien fait de special pour obtenir le droit en ecriture.
C’est assez zarbi si ca marche dans un Term et pas dans le Finder …
Je regarderais sur mon ibook ce soir.

Note: ma config samba me parait similaire à la tienne

merci, j’attends de tes nouvelles!
Il faut vraiment que j’épuise toutes les idées avant le dernier recours auquel j’ai pensé, qui ne me plaît pas des masses (ftp…). font ch… ces mac users! (Caf, si tu nous lis :P)

Salut
Ta es ce ke tu vois au moins les repectoires de ton serveur samba sous mac os?

[quote=“sose, post:4, topic: 29472”]Salut
Ta es ce ke tu vois au moins les repectoires de ton serveur samba sous mac os?[/quote]

sose. haha je te préviens tout de suite. Relis-toi. Ici on déteste l’écriture style sms, et en plus on ne comprend rien à ce que tu écris. Avertissement sans frais pour cette fois-ci, et je suis gentil, je ne mets même pas de warning. Mais gaffe. Ne recommence pas.

Salut
Par rapport à la question posé sur le serveur samba, je pense qu’il faut juste activer le client smb sous mac os . et ca devrait allé. J’ai eu le même probleme et je l’ai résolu.
Voila voila
PS :DSL si mon mon message n’était pas clair au départ

Que veux-tu dire par “activer le client smb”? sur les postes mac, il me semble que c’est ce que j’utilise quoi qu’il arrive pour me connecter au partage samba.

laisse le moi Cold…allé quoi laisse le moi…
B)

Mais je t’en prie B)

  • La commande que tu lances en CLI est probablement différente de celle qu’utilise le Finder pour se connecter. Chez moi, quand je monte un partage smb, le Finder lance ça :

422 ?? S 0:00.00 /sbin/mount -t smbfs -o noautomounted -o browse //server/partage /Volumes/partage 423 ?? S 0:00.04 /sbin/mount_smbfs -o noautomounted -o browse //server/partage /Volumes/partage

J’imagine que ça exécute la même chose chez toi, compare avec la ligne de commande que tu tapes manuellement et qui marche.

  • Ca donne quoi au niveau des logs ?

  • Autre chose, tu peux essaer de sniffer les trames pour voir si ce sont les mêmes qui passent dans les deux cas.

Je me permets de déterrer ce topic. Je n’ai pas trouvé les logs du client smb sur mac os (j’ai bien trouvé des logs, mais rien de parlant). Sous Samba, j’ai bien les logs, mais rien ne semble mentionner l’erreur qui se produit. Voici ce qui est affiché dans le log concernant le poste mac:

[quote][2006/08/31 15:33:13, 3] smbd/process.c:process_smb(1091)
Transaction 79 of length 44
[2006/08/31 15:33:13, 3] smbd/process.c:switch_message(886)
switch message SMBchkpth (pid 15579) conn 0x83b8b58
[2006/08/31 15:33:13, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (1035, 1035) - sec_ctx_stack_ndx = 0
[2006/08/31 15:33:13, 3] smbd/reply.c:reply_chkpth(593)
chkpth . mode=5
[2006/08/31 15:34:13, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/08/31 15:34:13, 3] smbd/process.c:process_smb(1091)
Transaction 80 of length 44
[2006/08/31 15:34:13, 3] smbd/process.c:switch_message(886)
switch message SMBchkpth (pid 15579) conn 0x83b8b58
[2006/08/31 15:34:13, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (1035, 1035) - sec_ctx_stack_ndx = 0
[2006/08/31 15:34:13, 3] smbd/reply.c:reply_chkpth(593)
chkpth . mode=5
[2006/08/31 15:35:13, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/08/31 15:35:13, 3] smbd/process.c:process_smb(1091)
Transaction 81 of length 44
[2006/08/31 15:35:13, 3] smbd/process.c:switch_message(886)
switch message SMBchkpth (pid 15579) conn 0x83b8b58
[2006/08/31 15:35:13, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (1035, 1035) - sec_ctx_stack_ndx = 0
[2006/08/31 15:35:13, 3] smbd/reply.c:reply_chkpth(593)
chkpth . mode=5
[2006/08/31 15:36:13, 3] smbd/process.c:process_smb(1091)
Transaction 82 of length 44
[2006/08/31 15:36:13, 3] smbd/process.c:switch_message(886)
switch message SMBchkpth (pid 15579) conn 0x83b8b58
[2006/08/31 15:36:13, 3] smbd/reply.c:reply_chkpth(593)
chkpth . mode=5[/quote]
Pour info, je suis en log level 3.
Une précision: On s’est mal compris, je n’utilise pas de ligne de commande pour me connecter au partage. Ce que je fais, c’est d’utiliser le menu “Aller à…” puis “se connecter au serveur” dans le finder. Ensuite, une tentative d’écriture sur le partage ne fonctionne pas via le finder, mais marche parfaitement en utilisant une ligne de commande dans le terminal!

Justement, je t’ai dit de comparer la commande que lance le Finder avec celle que tu lances en CLI pour tester et qui marche !

Ok alors pardon d’avance pour la question de noob mac qui n’a pas le temps/l’envie de chercher: Où trouver la ligne de commande lancée par le finder?

Au moment où le Finder te demande un login/pass pour accéder au partage smb, tu va dans le terminal et tu lances la commande :

(tu peux ignorer les lignes avec “automount”)