SEO d'un site

Bonjour à tous,

je suis en train de réaliser un site pour l’association que monte ma femme avec son associée.
Pour ce faire j’ai utilisé un template one page trouvé sur internet que j’ai customisé.

Le nom de domaine est sur OVH, j’ai aussi fait une redirection https.

J’ai demandé à Google et Bing de référencer le site.
Déjà, avant de mettre la balise permettant de mettre une URL canonique, l’inpecteur d’URL me disait que la page était en doublon d’un autre site, basé d’ailleurs sur le même template.
J’ai ensuite rajouté l’URL canonique sans plus de succès avant de m’apercevoir que j’avais renseigné l’URL http au lieu de https. Bon depuis ce matin c’est mieux, il ne me sors plus de doublon d’url canonique.

Sauf que dans les résultats de recherches j’ai des choses différentes.

Sur Bing :
image

Et

image

Sur Google, déjà ffar ne me donne pas le site dans au moins les 4 première pages de résultat. Ensuite :

Et

J’ai du mal à comprendre les différents résultats.
Pourquoi sur bing ffar et ffar.fr ressortent le bon site mais de manière différente.
Pourquoi sur Google ffar.fr renvoi le contenu générique du template (qui en fait me fait penser au site qu’ils m’avaient mis en url canonique, basé sur le même template mais qui était resté sans personnalisation https://www.clubatenea.com/) alors que le www.ffar.fr renvoi le bon truc, mais personne ne tappera ça.

BREF, est-ce que quelqu’un s’y connait pour me donner quelques tuyaux afin d’uniformiser les résultats ?

Merci d’avance :slight_smile:

1 « J'aime »

J’ai pas de réponse à ta question, mais on ne parle pas de SEO et pas CEO?

1 « J'aime »

Oui c’est tout à fait exact :smiley:

Parce que 302:

Le code de réponse HTTP 302 Found est une manière classique de réaliser des Redirections d’URL non permanentes. (dixit Wikipedia)

En gros, si tu vas sur ffar.fr (en http ou https) ou sur www.ffar.fr (en http), il répond 302 avec l’url https://www.ffar.fr et le navigateur va sur la redirection. Et c’est un fonctionnement normal.
Par contre, quand le robot google va sur ffar.fr, il se mange aussi 302, ce qui ne lui convient pas trop, donc il va tester d’autres fichiers sur le site: index.html, index.htm et sûrement plein d’autres fichiers dont j’ai pas idée. Donc quand tu lui demande ffar.fr, il va te répondre ce qu’il a trouvé en farfouillant au pif dans ton serveur web.
Par contre, quand tu demandes www.ffar.fr, comme il obtient une vrai réponse (200) en https, il propose ce qu’il a trouvé sur https (et pas sur http)

Il faudrait donc faire une minipage très basique pour les accès en http pour que google ait la bonne description. Mais ca, ca dépend de ton CMS et j’avoue que je ne sais absolument pas comment faire…

Pour bing, je pense que les raisons sont similaires, juste qu’il ne va pas farfouiller dans les mêmes fichiers.

Humm merci pour ce début de réponse.

Juste c’est pas un CMS, c’est juste une bête page html.
Je te confirme que j’ai bien un index.html qui est donc ma page du site.

Par contre je ne vois pas trop comment faire ton histoire de minipage.

Huum je m’y prends peut être mal, mais quand je fais un GET en telnet, je me mange un bad request. Je connais pas NGINX, est ce que tu as deux sites distincts quand tu fais un site http et un site https?
Et surtout, je sais pas du tout ce que bing ou google peut aller farfouiller dans ce genre de cas, donc même si je peux te donner une hypothèse d’explication, je suis pas sur de savoir comment régler le problème :cold_sweat:

Non j’ai qu’un seul site. Ne m’y connaissant pas trop, par contre j’ai fait une redirect htaccess pour basculer automatiquement toute requêtes vers le site en https. Après j’ai trouvé le script sur internet donc y’a peut être mieux à faire

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://www.ffar.fr/ [R,L]

Si c’est toi qui gère le redirect, désactive le et regarde sur quelle page ton navigateur va en http.
Si ca va bien sur la page du site https, c’est que google conserve dans son cache l’ancienne page du site. Il faudrait redemander un scan du site.

Ça ne vient pas du paramétrage qu’on fait du site et/ou du domaine chez l’hébergeur, en www ou non en préfixe ?

Non justement j’ai mis la règle car si on tapait ffar.fr, site restait sur la version http://ffar.fr alors que je voulais aller vers le https.

Mais y’a peut être un truc à faire niveau hébergement ovh directement.

hum je me suis mal exprimé:
Sans la redirection, est ce que ffar.fr (http) affiche la même chose que ffar.fr (https)?

J’ai désactivé la règle et oui http://ffar.fr/ et https://ffar.fr/ affichent bien la même chose.
par contre je viens de voir que taper ffar.fr dans la barre d’adresse va bien vers https://www.ffar.fr/ automatiquement on dirait, du coup je n’ai pas vraiment besoin de la redirection.
EDIT : ha non ça le fait sur chrome mais pas firefox, il reste en http.

Sinon au cas où, les trucs que j’ai dans la zone DNS ovh :



image

Redemande un scan de ton site par google et quand les deux cas sont OK, tu pourras remettre la redirection.

1 « J'aime »

Merci, je vais essayer ça :slightly_smiling_face:.

Je ne m’étais jamais posé la question de comment c’était galère ces référencements.
J’ai essayé Qwant. C’est rigolo. Juste ffar renvoi le bon titre du site mais avec une description encore différente des autres. Mais en première place.
Par contre ffar.fr et www.ffar.fr ne retourne rien :exploding_head:

Et duckduckgo, aucune référence. Cool :stuck_out_tongue: