[Serveur Dédié] Sites inaccessibles

Hello la zone,

J’ai un serveur dédié Kimsufi, hébergé chez OVH donc, avec 7 sites, 9 bases SQL et un relais audio qui est quasi jamais utilisé.

J’ai Ubuntu 10.04.4 Lucid qui tourne dessus avec fail2ban, apache, mysql… Le paquet de base. Les paquets sont à jour excepté le kernel (faut que je le fasse avec un pro linux.).
J’ai rien installé d’exotique.

Mon problème c’est que par moment les sites hébergés sont juste inaccessibles via le net mais j’ai quand même accès au serveur en ssh ou via l’interface web/iOS d’OVH.

J’ai regardé les logs, 0 message d’erreur, j’ai contacté OVH ils ont rien vu d’anormal par contre sur le monitoring ça donne ça:


Sur le forum j’ai pas eu de réponse non plus.

Quelqu’un a une idée ?

Top est ton ami. Ou alors, tu cron toute les secondes un log et tu regardes quand ca monte trop haut.

J’ai un pote qui a exactement le même souci que toi, toujours chez OVH sur un kimsufi, y a un processus qui lui bouffe tout le CPU à certains moments, il a toujours pas trouvé de solution et il a 50 fois moins de choses que toi sur son serveur.

Curieux le swap vide après l’absence. Peut-être un processus qui te bouffe toute la mémoire avant de planter ? Pour compléter ce que dit AnA-l, top c’est bien, mais htop est plus convivial.

Moe> ça correspond au hard reboot que j’ai fait je suppose…
Glasofruix> j’ai cherché le coup des 100% de cpu qui font planter la machine, personne n’a identifié le problème… Chelou.
AnA-l> j’ai fait un top, rien d’anormal, pas d’utilisation excessive du cpu ou de process inconnus :confused:

La seule solution serait de passer chez un autre hébergeur ?

Si tu avais toujours un accès SSH, pourquoi ne pas avoir redémarré Apache ? Tu peux tester un autre serveur, comme nginx.

et c’est tout le temps au même moment, où c’est complètement aléatoire ? 

[quote=“Dewax, post:5, topic: 54761”][/quote]

Si tu as toujours un acces SSH, ce n’est pas le réseau de OVH qui est tombé. Donc si tu change d’héberger et que tu remonte une config équivalente, tu risque juste d’avoir le même soucis. (peu probable quand même, mais c’est surtout pour dire que changer d’hébergeur ne résoudrait pas le soucis selon moi)

A vérifier quand ca arrive : quel est le status de apache ? php ? un process qui fout la merde ?

[quote=“Moe, post:6, topic: 54761”][/quote]
+1 Si ton accès SSH tourne mais plus les sites c’est probablement Apache qui patine.

pour voir le nbr de process apache qui tournent tu peux faire un :

ps aux | grep -c apache

I NEED MORE INFORMATIONS!
cat /proc/cpuinfo
cat /proc/meminfo
uptime
éventuellement la config apache/mysql/php

LoneWolf
Ultimatly, tu me file ton login/pass root ^_^;

[quote=“LoneWolf, post:10, topic: 54761”][/quote]

et dewax.net deviendra adopteungeek.net, un serveur bf3, un miroir pour morceaux choisis et peut etre meme un depot cydia en moins de temps qu’il n’en faut pour l’ecrire

[quote=« Moe, post:6, topic: 54761 »][/quote]

Quand on m’a signalé le souci j’avais que mon téléphone et l’appli ovh à portée :confused:

[quote=« mono, post:7, topic: 54761 »][/quote]

Complètement aléatoire, la dernière fois c’était en octobre, une autre fois en avril de mémoire…

[quote=« Haza, post:8, topic: 54761 »][/quote]

Je vérifierai quand ça arrivera… De mémoire c’est entre 17 et 20h que ça plante, pourtant vu les stats c’est pas du tout à cette heure là qu’il y a le plus d’activités sur le serveur.

[quote=« Ludwig, post:9, topic: 54761 »][/quote]

à 15h, y a 14 process apache, c’est trop ?

[quote=« LoneWolf, post:10, topic: 54761 »][/quote]

Intel Intel® Celeron® CPU 220 1 core 1.2GHz (512kb en cache)
2 go de ram
1 to disque dur

au moment du plantage il avait 45 jours d’uptime

[quote=« wackselwease, post:11, topic: 54761 »][/quote]

(je n’ose imaginer si il garderait ou non dailydredi ^^)

[quote=“Dewax, post:12, topic: 54761”][/quote]

connaissant le bonhomme, il garderait les photos, mais flouterait les castors 

[quote=“Dewax, post:12, topic: 54761”][/quote]
C’est trop pas ca la question.
Je veux le resultat de cpuinfo, meminfo et de la commande uptime, qui fournissent BEAUCOUP plus d’informations que ca.

[quote=“wackselwease, post:13, topic: 54761”][/quote]
Cachez ses poils que je ne saurais voir… 

LoneWolf
Putain c’est tellement vrai, j’en verrais jamais, a quoi bon les voir en retouché photoshop… bouhouhou

[quote=“Dewax, post:12, topic: 54761”][/quote]

Ca me parait pas énorme pour 7 sites, mais LoneWolf étant sur le thread je vais laisser parler les pros.

Un outil qui m’avait bien aider a trouver pourquoi un serveur plantait (memory leak de nodejs) :
http://newrelic.com/
Facile a installer et beaucoup de metriques

totalement hors sujet, mais pour motiver les troupes je vous propose une photo de castor, typique de ce que l’on trouve sur le kimsuffi de dewax
attention castor