Wake On LAN

Yop all,

Donc j’ai un petit souci avec le Wake On LAN de mon PC. �?a marche nickel quand je mets le PC en mode veille prolongée (configuration bios de la gestion d’énergie en S3, donc tout éteint), seulement cela ne marche pas quand l’ordi est éteint pour de bon. D’où les questions suivantes:

  • Est ce qu’il est possible de booter un PC en mode “éteint complet”, avec du WOL?
  • A défaut, est ce qu’on peut reprogrammer le bouton “Power” pour signaler à l’OS que “non tu fais pas un shutdown, tu fais une mise en veille prolongée”.

Sachant que j’ai comme carte mère une FN95 (Shuttle SN25P), et comme OS Windows 7. J’ai déjà réussi a remplacer le bouton “éteindre” du menu démarrer par “mettre en veille prolongée”. C’est juste que j’ai plus l’habitude du bouton power, et que donc j’oublie que le WOL marche pas avec ce bouton…

Tu dois mal t’y prendre pour faire ton WoL.
Quelle IP tu utilises ?

Bon alors c’est clairement pas un problème d’IP je pense, vu que le packet arrive bien jusqu’a la carte réseau; la petit led data de la carte réseau de l’ordi s’allume quand j’utilise le programme pour envoyer le magic packet, donc il le reçoit bien.

non mais tu broadcast ou utilises l’ip de la machine ?

Faut utiliser l’IP de la machine non?

Bah nan faut broadcast, vu que la machine est éteinte, elle n’a donc pas encore d’IP. Mais comme dit sur IRC, vais tenter le broadcast a 255.255.255.255 et pas sur 0.0.0.255

Non, justement, faut faire du broadcast.

wackelwease c’est ip + mac.

Oui et oui. De rien.

  • A défaut, est ce qu’on peut reprogrammer le bouton “Power” pour signaler à l’OS que “non tu fais pas un shutdown, tu fais une mise en veille prolongée” --> de mémoire c’est dans le bios ca.

Yep sauf que j’ai pas trouvé l’option dans mon bios Award…

Donc : c’est clairement pas un problème réseau ou de manip pour effectuer le WoL, vu que ca fonctionne en veille prolongée.

Donc change pas d’IP ou de paramêtres, ca c’est très bien.

Je penserais plutôt à un soucis de réglage dans le pilote de la carte réseau.

Le Wol fonctionne parce que le pilote mets la carte réseau dans le bon état avant de mettre la machine en veille prolongée. Il faut qu’il fasse de même avant le power off.

Sous Win7, tu ouvres le gestionnaire de périphériques, les propriétés de la carte réseau, et dans l’onglet avancé, tu cherche une option du genre “Shutdown Wakeup”, “Wake from Shutdown” ou “Wol from S5” …

Ok je vais regarder ca, merci pour toutes les pistes, j’ai du grain à moudre ce soir :).

Pour le bouton power qui met en veille prolongée c’est bien sûr possible. Je te décris la manip sous xp vu que je n’ai pas seven, mais je ne pense pas que cela change beaucoup entre les deux.

  1. Lancer le panneau de configuration
  2. Options d’alimentation
  3. Onglet “Avancé”
  4. Dans le cadre “Boutons d’alimentation” tu peux choisir l’action à effectuer lorsque tu appuie sur le bouton power.

Ipno

Bon, j’ai cherché, j’ai cherché… et j’ai pas trouvé :/. La configuration Windows semble bonne (j’ai presque tout pareil que http://wakeonlan.me/kb/tech/wakeonlan.php, je dis bien presque parce que les champ WOL sur le NForce 4 que j’ai sont pas identiques), la configuration BIOS semble bonne (quoique j’ai pas trouvé le paramètre PnP-OS, c’est ptet pour ca que Windows n’arrive pas à mettre à jour la config de la carte réseau?).

D’autres idées?

A priori je dirais dans le bios, bien vérifier que l’option wakeonlan est activée… Le fait que le pc se réveille en mode veille n’est pas lié au wake on lan à mon avis. Et pour réveiller un PC il faut l’adresse mac de la carte réseau (http://fr.wikipedia.org/wiki/Wake-on-LAN)

Bon après avoir regardé la doc de la CM, je dirais qu’il faut mettre l’option WOL from SoftOff sur Enabled. Par contre attention, il semble que si le courant est coupé pendant un instant, ça ne marcherait plus (j’ai lu des cas d’utilisateur de CM Asus). En gros il faut que le boitier soit alimenté en permanence.

Un petit up sur ce thread pour ajouter un petit problème que je rencontre, si c’est trop HS je posterai un nouveau sujet :

  • Le Wake on Lan fonctionne très bien, j’allume mon ordi depuis mon smartphone encore dans le lit :rolleyes:
  • Sauf que ça c’est pas ce que je voulais : l’intérêt que j’avais pour le magic packet était de pouvoir l’allumer depuis l’extérieur, donc du wake on wan.
    Alors là, ça marche pas.

Quand je suis sur le réseau, en adresse ip, je mets un banal 192.168.X.254, ou X est le numéro de l’ordinateur à réveiller.
Mais quand je suis à l’extérieur que dois-je mettre ? Mon Ip n’allume rien, rien ne se passe, aussi bien sur port 7 que 9. Je précise que j’ai une Freebox V6. Je dois manquer un truc, mais je sais pas encore quoi…

Merci !

Il faut activer le Proxy Wake On LAN dans l’interface d’administration (si elle est dispo pour les V6…)

Yep c’est fait, puisque le Wake on Lan fonctionne :). Le Wake on Wan par contre est toujours impossible, le paquet s’envoie sans réponse du PC…

Pour récapituler, tu fais bien un envoi de magic packet, sur ton ip publique free en indiquant l’adresse mac du pc à réveiller ?

Je réveille sans souci mon nas (synology) et mon pc à travers une freebox v6 (proxy wol activé) via l’application WOL Wake on Lan WAN sur android.