Configuration VPN et NAT reseau local

Bonjour !

C’est dans un désespoir que je fais appel aux forums, après environ 2 semaines de recherche, de ponçage de recherche google, après avoir parcouru toutes les recherches, je n’y trouve pas le bout… Néophyte comme je suis, j’espere pouvoir y arriver de par vos talents !

Je vais expliquer la situation en détail pour que l’on puisse peut être y comprendre plus clair :

-J’ai un modem PRINCIPAL de mon distributeur (VOO)(MODEM A) qui lui a une adresse ip réseau local 192.168.0.1. Qui d’ailleurs m’envoie sur la configuration du modem quand je rentre cette adresse.

-J’ai un modem XIAOMI 3G v1 sous OPENWRT(MODEM B) dans mon salon qui est donc connecté sur le port éthernet de mon modem VOO pour avoir internet et qui redistribue donc du WIFI, sur lequel sont connectés tous mes périphériques (téléphone, pc portable, tv connectée, box android) etc etc

Sur le modem B, j’y ai installé ARIA via le tuto du crabeinfo qui permet de télécharger des fichiers sur celui-ci sur une clé usb branchée dans le port usb.

J’y ai également installé un serveur vpn sur mon modem B également par le tuto de crabeinfo qui utilise le port 1194.
(Lien du tuto : [TUTO] Installer un serveur OpenVPN sur votre routeur OpenWrt / LEDE - Tutoriels et astuces - Le Crabe Info)

Seulement voilà je bloque, j’ai réussi à créer un compte sur changeip, quand je vais dans ma configuration je vois bien mon adresse http://www.xxx.dynamic-dns.net avec l’adresse ip qui semble juste puisque c’est celle qui s’affiche sur whatismyip.com

Le probleme, c’est que quand je connecte mon client VPN, impossible de me connecter à mon modem B si je suis pas connecté à son wifi. par exemple en 4G la connection au VPN ne va jamais se faire.
Pire encore, même si je suis sur le même wifi et que la connection vpn veut bien se faire … je n’ai pas internet et encore moins acces à son réseau local de toute façon…

Là où est je pense le problème, c’est sur « l’ouverture des ports ou redirection » je ne sais pas trop, je cite le point où je ne comprends pas ce que je dois faire sur le tuto :
« Enfin il faut faire la redirection de port pour que les requêtes du VPN soit dirigées vers votre routeur sur lequel est installé le serveur OpenVPN »

Je vous joinds une capture d’écran de ma config NAT sur mon [b]Router A[b] qui est donc mon modem PRINCIPAL (VOO)

J’espere que vous avez tout, s’il vous plizzzzz je m’en sors vraiment pas :frowning:

Sur les réseaux 3G/4G et leurs APNs accessibles aux particuliers, t’es NATé (pas d’ip publique dédiée) et donc tu peux pas exposer de ports. Le seul contournement dans ce genre de cas c’est de faire des forwardings de ports du modem B vers une autre machine qui elle a une vraie ip publique accessible.
C’est probablement pas la solution la plus propre, mais ça peut se faire en SSH avec l’option -R.

Sauf si tu as un abonnement/modem/routeur spécifique 4G box.

Huum vous partez loin dans le délire là et @nicoo1420 n’a pas parlé de carte SIM dans son modem XIAOMI 3G v1. Il a juste embrouillé son monde avec son histoire de connexion 4G/Wifi avec son smartphone qui ne marche pas, ce qui est un peu normal.

Bref, on va faire des schéma dégueu en ascii art.

Il a configuré ca (je pense):
(Internet) <-> (Voo - modem A) <-> (Xiaomi - modem B) <->WIFI Only.

Il veut faire ca (the real deal):
(Smartphone 4G) < -OpenVPN- > (Internet) < -OpenVPN- > (Voo - modem A) < -OpenVPN- > (Xiaomi - modem B) < -OpenVPN- > (Réseau local)

Il a tenté ca:
(Smartphone Wifi) < -OpenVPN- > (Xiaomi - modem B) < -OpenVPN- > (Réseau local)
Qui ne peut pas fonctionner car le smartphone en wifi est deja sur le-dit (Réseau local) (donc c’est con-con).

Donc, on revient sur The real deal. Effectivement, ça marche pas et ça peut pas marcher car il manque un truc dans ton (Voo - modem A): Tu as ouvert le port 1194, c’est parfait mais ce port ne sert qu’a l’initialisation de la connexion. Tu dois aussi autoriser le protocole TUN (ou TAP en fonction de ta config) a passer au travers ton modem A pour aller sur B.
Pour moi, ca marchera pas car c’est pas du port forward, c’est du protocole forward et la seule manière de s’en sortir, c’est d’utiliser le fameux mode DMZ (dispo dans pas mal de routeur, et d’après le screenshot, tu as ca) qui balance tout l’entrant de ton modem A sur la machine de ton choix (ici le modem B donc). Si tu fais ca, plus besoin de port forward sur modem A, mais il va falloir être au taquet sur les mises a jour du modem B (et des appareils du réseau local) car tout ton trafic entrant passera sur ton réseau local: Je te le déconseille fortement.

D’ailleurs, je suis même pas sur qu’un protocole forward soit possible sous Linux, faudrait que je regarde a l’occasion.

Ouawww tu as tout compris !
Et effectivement tu as aussi compris qu’il 'e s’agissait pas de router avec carte sim mais bien le modèle dit 3G « 3 EME génération »

J’avance doucement dans les pistes, une connaissance m’a dit de mettre mon modem VOO (modem principal de mon fournisseur internet) en mode bridge et mettre ensuite sur mon router mettre mon LAN sur client DHCP et plus IP statique…

Ceci dit je ne vois toujours pas comment accéder au réseau local depuis l’extérieur :disappointed_relieved:

Déjà de base mettre le routeur voo en bridge c’est une bonne idée, ça évite de se retrouver avec un double nat, faut juste penser à désactiver le wifi dessus.
Ensuite connaissant voo, t’es peut être en CGN et tu peux de suite oublier le vpn. En gros tu es en ip privée avec une ip publique partagée entre plusieurs autres usagers (du au manque d’adresses ipv 4). Tu peux vérifier en te connectant dans l’interface du modem et voir l’ip qu’il t’attribue, de mémoire c’est dans le réseau 10.x.x.x. Normalement il suffit de les appeler et de demander à ce qu’ils te mettent une ip publique.