Connexion bureau à distance (mstsc) entre Win10 sans mot de passe. Possible?

Hello,
Petite question simple du dimanche soir : est ce qu’il est possible de se connecter en bureau à distance à un PC sous Win10 sans utiliser de mot de passe ? J’avais testé y’a 2-3 ans et c’était impossible (bug potentiel d’après ce que j’avais lu pendant mes recherches).

Pour le contexte, j’utilise actuellement un NUC d’Intel comme box Média. Comme il est dans le salon je n’ai pas de clavier à dispo, donc je n’ai pas mis de mot de passe sur ma session. Tout doit pouvoir se piloter à la souris.
Pour toutes les « grosses » actions, je les fait depuis mon ordi principal (sous Win10) en me connectant via bureau à distance sur le Nuc (les PC sont sur le même domaine).
Avec Win7 installé sur le Nuc, aucun souci.
Avec Win10 par contre cela ne fonctionnait pas. J’avais testé lors de la possiblité de migrer de Win7 vers Win10. Le bureau à distance se lançait mais j’avais accès au Nuc pendant même pas 10 secondes avant d’être déconnecté. D’après mes recherches, la session sans mot de passe se lançait aussi et déconnectait la session bureau à distance.

Comme je compte changer de Nuc dans pas longtemps et pourquoi pas retenter Win10, je me demandais si maintenant ce bug (si c’en est un) était corrigé. Je souhaite éviter d’utiliser des logiciels tiers genre TeamViewer.

J’ai pas compris à partir de quoi (en dehors de ton ordi principal) tu te connectais à ton NUC du coup ?

Normalement, Remote Desktop sur Windows 10 requiert un mot de passe. Sans ça, point de salut. Il semble qu’il existe une manip’ via la base de registres, mais elle date un peu, du coup je ne sais pas si c’est toujours fonctionnel.

En même temps, pas de password c’est mal.

1 J'aime

Avec une souris uniquement. Comme il n’y a pas de mot de passe sur le Nuc, je peux rentrer dans la session directement.
@Faskil : oui j’avais testé cette technique à l’époque mais elle ne fonctionne pas complètement. Tu arrives à te connecter en effet, mais tu te fais éjecter directement après.
J’espèrais que cette fonctionnalité qui existait sous Win7 revienne à un moment. :confused:

Peu probable. Pourquoi ne pas utiliser le on-screen keyboard ?

Pourquoi ne pas mettre un mot de passe sur le nuc et de faire un auto logon de session ?

edit: lorsque tu quittera la session ts ça redemandera le mot de passe.
On oublie.
La solution est peut être se tourner vers un teamviewer ou VNC ou splashtop ou autre que ne touche pas aux sessions

1 J'aime

Nope, on peut pas sous win 10. Après rien ne t’empêche de mettre un mot de passe à la con à la session et de faire un petit coup de netplwiz pour désactiver la demande de mot de passe au boot. Par contre ça verrouille la session à l’écran, on peut pas utiliser une même session à deux endroits différents.

Ou effectivement passer par un anydesk par ex.

Tu te créé un compte avec mot de passe (pour l’admin à distance) et un autre sans mot de passe (pour y accéder du salon) ? Mais encore une fois je ne suis pas sur que Windows 10 autorise d’avoir un compte sans mot de passe.

Tu utilises un code Pin avec le clavier virtuel ?

Et utiliser un gestionnaire de session du genre Remote Desktop Connection Manager c’est possible ?
Ce genre de soft permet de sauvegarder les mot de passe et donc il y a juste à cliquer pour lancer la session (oui, c’est mal).
En entreprise, ils activent souvent une GPO pour interdire la connexion à partir d’identifiants sauvegardés mais je pense pas que ça soit le cas par défaut (ne serait ce que parce que ça marche sur mon poste de travail, là tout de suite :slight_smile: )

http://wdc3.custhelp.com/app/answers/detail/a_id/20736/~/how-to-enable-smb-1.0%2Fcifs-file-sharing-support-on-windows-10

edit:

Si si on peut et je viens de retester sur un poste. Avec mon second lien. Le 1er lien est pour que la découverte réseau fonctionne avec ce type de compte.

Une piste serait de voir s’il est possible de configurer RDP pour une connexion avec certificat client, au lieu d’un mot de passe.

Je vois un thread qui évoque ça ici :

Je ne suis pas certain que ça soit faisable, mais j’ai l’impression que ça répondrait à ton problème si c’était le cas.

C’est surtout que si tu ouvres une session rdp, tu prendras la main sur la session, c’est probablement plus judicieux de faire du vnc ou équivalent pour éviter d’avoir à rouvrir la session à chaque fois.

En plus tu n’es pas obligé de mettre un mdp à la session pour utiliser le vnc :slight_smile:

Aller une autre réponse àlaGZ:



3 J'aimes

Je me demandais quand elle allait arriver cette solution… :rofl:

2 J'aimes

Par curiosité j’ai regardé si la solution d’une authentification à base de certificats est possible pour RDP : la réponse est malheureusement non.

Il te reste la possibilité d’utiliser des clients tiers qui stockent le mot de passe pour rendre la connexion plus facile. Apparemment mRemoteNG le fait.

1 J'aime

Mais sinon, comme dit plus haut, OSK, ça me semble quand même être la solution idéale qui allie sécurité et facilité d’accès sans clavier physique.

@zepostman
Quelque chose doit m’échapper : en quoi ma solution d’autoriser les sessions invités ne répond pas au problème ? Sur le Windows 10 que j’ai sous la main ça permet les connexions rdp sans mot mot de passe. :slightly_smiling_face:

En tout cas merci pour les réponses. Ça confirme ce que je pensais, j’ai eu l’espoir qu’une maj fasse un correctif sur ce point. Tant pis. Je testerais les solutions dans pas longtemps vu que je reçois le nouveau Nuc cette semaine.
@Faskil, c’est clair qu’il fait le taf vu que c’est ce que j’utilise quand je dois taper quelque chose. Mais il m’a fait faux bond une ou deux fois au démarrage, justement quand j’étais passé sous Win10 m’empêchant de me logger. J’avais rollback sous Win7 à cause de ça. Je lui redonnerais sa chance. Ou au pire je passerais sur du physique.

@phili_b le souci c’est que je m’exprime mal et que j’ai posé la problématique à l’envers :smiley:
Mon souci principal c’est que la connexion rdp (avec ou sans mot de passe) ferme la session en cours (même si il n’y a qu’un utilisateur sur la machine). Du coup ça oblige à me reconnecter, et quand je suis dans le salon, taper le mot de passe avec le clavier virtuel c’est reloud. Je peux tester le guest à voir si il aura assez de droits pour traficoter comme j’en ai besoin.

Merci encore pour les reco en tout cas.

1 J'aime