Debit lent sur carte wifi realtek 8821AE, wifi ac

Bonjour a tous,

J ai un Dell XPS13 L322X avec windows 10 X64.

J’ai changé la carte wifi d’origine pour une Realtek 8821AE, qui à priori est à la norme 802.11ac.
Je ne depasse pas le 80Mbits en test de debit descendant.

Sur mon telephone j’atteint au moins les 400Mbits en norme « ac » sur le wifi 5G.

Je suis bien connecté sur le reseau « 5G » de ma freebox mini 4K, en fibre (1GBps).
Dans la gestion du wifi de la freebox il est indiqué comme etant bien connecté sur la version 5G du wifi mais en norme « n » au lieu de « ac ».

J’ai mis a jour le driver de ma carte par la derniere version que j ai pu trouver la 2024.0.4.108 de 22/03/2019.
J’avais auparavant le driver « Microsoft » 2023.70.109.2018 du 09/01/2018, infos de la carte (PCI\VEN_10EC&DEV_8821&REV_00)

Dans les reglages du gestionnaire de peripherique, j’ai ces options:

  • 802.11d : Activé (ou desactivé)

  • Intervalle balise : 100 (ou valeur numerique au choix entre 20 et 1000)

  • Mode preambule : long and short ( ou preambule long)

  • Mode sans fil : Auto, 802.11a/n/ac et 802.11b/g/n (ou 802.11a , 802.11a/n , 802.11a/n/ac , 802.11b , 802.11b/g , 802.11b/g/n)
    J’ai essayé Auto, 802.11a/n/ac et quand je choisi 802.11b/g/n je ne trouve plus mon wifi 5G.

  • Multichannel concurrent : disabled (ou enabled)

  • Roaming sensivity level : low ( ou desactivé, high, middle)

  • Wake on magic packet : activé (ou desactivé)

  • Wake on pattern match : activé (ou desactivé)

Voila, je suis un peu perdu, auriez vous une idée, svp? une piste à explorer?

Merci

Ça peut être la position du point d’accès wifi par rapport à l’antenne de la carte sur ton PC. As-tu testé en mettant ton téléphone à peu près à la même position ?

je suis au même endroit pour les 2, soit une dizaine de mètres sans obstacle.
Et, a priori, je ne pense pas que la distance ferait que je ne puisse pas me connecter en wifi « ac », et seulement en « n »? si?

Ah mince, désolé. J’avais vu le 40 Mb mais pas le wifi n dans ton message.

Si tu peux changer de canal côté freebox, teste un canal plus bas sur le 5 Ghz( <100).
Sinon, c’est pas impossible que ta carte soit pas connectée aux antennes du laptop, check de ce côté.
Je viens de check, y’a qu’une seule antenne sur cette carte :frowning:

Tu es sûr que physiquement les antennes du portable savent capter du WiFi AC ?

y a une différence entre une antenne pour wifi ac et wifi n ???
et vu que je tente de me connecté en étant vraiment a coté de la box, je devrais pouvoir me connecter sans même avoir les antennes de branchées, non?

Je pense que tout est bien connecté…

Je viens de passer sur le canal 36 et 40, même résultat je suis connecté en « n » au lieu du « ac »

Alors je ne garantis pas mon raisonnement mais je dirais que oui :

New technologies introduced with 802.11ac include the following:[5][11]

  • Extended channel binding
    • Optional 160 MHz and mandatory 80 MHz channel bandwidth for stations; cf. 40 MHz maximum in 802.11n.
  • More MIMO spatial streams
    • Support for up to eight spatial streams (vs. four in 802.11n)

Un part importante de la captation du signal WiFi c’est quand même le nombre d’antenne et la fréquence qu’elles arrivent à capter.

Pareil, la comparaison est peut-être « limite » mais sur ma carte mère d’ordinateur fixe, si je ne visse pas d’antenne, je n’ai pas de bluetooth.

1 « J'aime »

Il semble bien que ce soit un problème de driver, quand je me connecte en ayant booté sur un petit kaly linux live, je suis détecté en « ac » par la freebox et je monte au moins jusqu’à 230Mbits, ce qui est pas 800Mbps mais c’est déjà une avancée.

Il va falloir que je cherche un autre driver…

petit update, bien decevant, j ai essayé toutes ces versions de drivers, toujours, le même problème…

2012.13.402.2014
2023.56.502.2017
2023.70.109.2018
2024.0.4.108
2024.0.4.208
2024.0.4.209

C’est pas choquant:
image
En wifi 5, tu as 433Mbits/sec maximum par antenne, donc si tu n’as qu’une seule antenne, ca donne 433 maxi du maxi, soit en gros 200 a 250Mbits/sec rééls. Tu dois pouvoir maxer le truc a 300-ish avec le vent dans le dos.

Par contre, c’est effectivement etonnant que tu sois bloqué en N sous windows… :thinking:

Tu peux forcer le type de wifi utilisé dans le panneau de configuration ? J’ai été obligé de faire ça à chez moi pour que ma carte (basée sur une puce Intel par contre) se décide à utiliser le wifi 5, sur les canaux 5 GHz.

j ai déjà tenté ça, en sélectionnant 802.11a/n/ac, je suis bien connecté sur le reseau 5ghz mais toujours en norme « n » à maximum 100Mbits.

Salut.

As-tu contacté Realtek ?
Vu que tu as bien bossé côté tests, peut-être les aideras-tu à dégoter un bug, voir à mettre en place une correction pour un futur correctif…

Je n y avais pas pensé, je viens d’envoyer un mail, sans grande conviction, mais on sait jamais…

En fait, sur ma carte, je peux non seulement forcer la bande de fréquence, mais aussi le protocole wifi employé :

image

Évidemment, ce n’est pas la même puce donc les options diffèrent peut-être, mais ça vaut le coup d’essayer.

Je n’ai pas ces options la, seulement le choix du mode sans fil…