[FREEPLAYER]Port triggering, comment ça marche ?

Bonsoir,

Possesseur d’une freeboîte j’ai voulu configurer tout ça pour pouvoir regarder la télé sur l’ordi.
Après quelques déboires, mon ami google m’apprend que le problème vient de mon routeur (Linksys WRT54G).
Après d’autres recherches, google m’apprend qu’il faut que je configure le routeur pour :
port triggerring : 554 to 554 : port fordwarding : 1025 to 65535
Bon je le fais, ça marche. Content.

Par contre, google ne m’explique pas bien comment fonctionne le port triggering et pourquoi on y rajoute du fordwaring (ben oui j’aime bien comprendre ce que je fais).
Si quelqu’un peut m’expliquer ou me donner un lien bien foutu, merci.

heu attends la…

dejà les plages d’ip que tu donne ne m’ont pas l’air tout à fait les bonnes:

pour le freeplayer il faut ouvrir le port 1234 en UDP et le port 8080 en TCP.

mettons que ton PC soit sur l’ip 192.168.1.2 (avec donc un routeur 192.168.1.1), il faut déclarer à ton routeur de forwarder ces deux ports là (en faisant gaffe au protocole TCP ou UDP) vers l’ip de ton PC.

donc: port forwarding port 1234 protocole UDP vers 192.168.1.2 et port 8080 protocole TCP vers 192.168.1.2

le port triggering sert à déclencher l’ouverture d’un port à partir du moment ou ton PC envoie une requête (en gros: si ton PC demande une donnée sur le net qui doit passer par un port précis, ce port sera ouvert automatiquement par le routeur).

Le port forwarding lui sert à déclarer au routeur des ports qui doivent tout le temps rester ouverts et vers quel PC le flux doit être dirigé, sans être embétés par le firewall, ce qui fait que les données vont pouvoir passer dans le sens net vers PC.

Le fait de te mettre en port forwarding sur une plage aussi vaste est non seulement inutile, c’est aussi dangereux puisque tu désactive le firewall sur 90% des ports utilisables, ton réseau devient dès lors un vrai aimant à vérole.

Je pense que le monsieur veut parler de Multiposte et non de Freeplayer, mais sinon ta réponse reste correcte.

erf…

bon heu…

heum…

passe pour un gland moi sur le coup là…

pour le multiposte (et non le freeplayer) les ports sont…

TADAAAAAM: 31336 et 31337 en UDP uniquement

Et il faut bien faire attention à ce que ce pitre de VLC reste bien calé sur ces deux ports (il a un peu tendance à modifier les ports comme bon lui semble sinon)

Déjà merci pour la réponse.
Par contre, pour les ports 31336 et 31337, si je les fordwarde ça marche pas. Mon ADSLtv (http://adsltv.free.fr/) n’affiche rien. Par contre si je recolle la règle précédente (port 554) ça remarche.
J’ai raté un truc ?

autoquote:

c’est de là que vient surement le problème, selon les versions de vlc les ports sont diférents et/ou non fixes.

tu as deux solutions à tester:

soit si tu dispose d’une page sur la config de ton routeur où tu peux définir des zones de confiance (donc pour laquelle les ports sont libres d’accès) mets y l’adresse " mafreebox.freebox.fr "

sinon utilise la version modifié de l’install d’adslTV par crazyfred (la deuxième) et va dans paramètres/préférences/input-codecs/demuxers/rtp-rtsp , là coche en bas à droite la case “options avancées” et définie alors le port à utiliser en udp. Cette deuxième solution a un mauvais coté en revanche: l’adsltv ne dispose que d’un seul canal donc: pas de flux multiple vers ton pc (en gros pas d’enregistrement en même temps qu’un visionnage) et surtout un seul PC sur le réseau obtient le signal.

OK.
Merci beaucoup.