Internet Explorer, c'est (presque) fini !

Article publié sur : http://www.geekzone.fr/2016/01/06/internet-explorer-cest-presque-fini/
L’année vient à peine de commencer, et on pleure déjà à chaudes larmes les décès de Michel Delpech ou Galabru, mais on oublie qu’ils ne sont pas les seules victimes prématurées de 2016. Dans l’indifférence quasi générale, Internet Explorer s’apprête également à passer l’arme à gauche. Enfin, j’exagère un peu : pour l’heure, seules les…

2 « J'aime »

Du côté des développeurs, on est bien évidemment ravi et on danse allègrement sur les tombes des versions abandonnées : pour eux, cette mise au rebut signifie avant tout une charge de travail considérable en moins pour rendre leurs sites compatibles avec ces butineurs désuets.

C’est moche de remuer le couteau dans la plaie, TU SAIS QUE C’EST PAS VRAI.

3 « J'aime »

Mais dès mardi prochain, toutes les autres itérations d’IE ne seront plus supportées par Microsoft.

Nuance (tiré de cette page):

Beginning January 12, 2016, only the most current version of Internet
Explorer available for a supported operating system will receive
technical supports and security updates.

Et par “most current version of Internet Explorer” ils entendent:

Windows Vista SP2: Internet Explorer 9
Windows 7 SP1: Internet Explorer 11
Windows 8.1 Update: Internet Explorer 11

1 « J'aime »

Vista est en fin de cycle aussi en fait (le support mainstream est fini), et je pense que c’est pareil pour Windows Server 2008. Donc grosso modo, ça sent la fin des haricots pour tout ce qui n’est pas IE11. Mais tu fais bien de nuancer. :wink:

Normalement, les banques vont nous aider a nous débarrasser des vieux IE.

En gros, le PCI SSC, un organisme qui émet des recommandations de sécurité sur les paiements par carte, qui sont apparemment bien suivies, a annoncé que SSLv3 et TLS1.0 n’étaient plus acceptables pour faire transiter des infos de paiement.

Donc il faudra du TLS > 1.0 pour pouvoir utiliser un système de paiement, ce que ne supporte pas IE < 10, et encore c’est compliqué pour IE10.

À l’origine, la date limite pour la mise en conformité des systèmes était Juin 2016, mais en décembre le PCI SSC à annoncé que la deadline passait à 2018, dommage :frowning:

2 « J'aime »

Cela dit, vu que les mises à jour d’IE sont maintenant automatiques, la plupart des utilisateurs n’y verront que du feu. IE 11 pour quasiment tout le monde.

A part les grosses entreprises bloquées sous IE 6, bien sûr :wink:

Le problème c’est que seul Windows 10 permet d’avoir Edge, donc on va ce retrouver à devoir supporter IE11 pour toute les personnes qui reste sous W7 et W8 et vu le temps qu’il a fallut pour que les gens arrête d’utiliser XP, ce sera surement pour encore de très nombreuse années !!!
Ça ne m’étonnerais pas que IE11 devienne le IE6 des prochaines années, les frontend développeur vont pouvoir râler sur IE pour encore un bon bout de temps :wink:

Je vous parie que dans 6 mois j’ai encore ça

Imposé malgré mes demandes répétées…

1 « J'aime »

Franchement IE11 ça va, ça permettrait déjà par exemple de passer sur du Flex alors que IE10 ne le supporte que partiellement. :slight_smile:

Ça va maintenant, mais dans 2/3 ans ce sera chiant d’avoir des gars encore sous Windows7/8 avec IE11 :frowning:

J’espère qu’ils changerons d’avis et qu’on pourras installer Edge sur W7/8 !

1 « J'aime »

Mouais je ne serais pas si enthousiaste…en tout cas à court terme.

Notamment sur google doc/ calc il y a quelques bugs énervants sur Edge qui n’existent pas sur IE (molette de souris foireuse, icône aux fraises). Sans parler de l’ergonomie foireuses des onglets et menus d’Edge quelque soit le site.

Et surtout, je ne sais plus où j’avais lu ça, Edge ne sera pas si différent d’IE: pour preuve les bug fixes simultanés et identiques sur les 2 logiciels.