Lenteur wifi dans un sens pas dans l'autre

Bonjour tout le monde

j’ai un ptit soucis et je vois pas d’où ça peut venir…je m’explique

j’ai un routeur sous OpenBSD avec 2 réseaux dessus, un filaire et un autre wifi

lorsque je lis une video se trouvant sur le portable connecté sur le réseau wifi à partir d’un des pc du réseau filaire aucun souci

par contre lorsque je tente de lire une vidéo se trouvant sur un des pc connecté sur le réseau filaire à partir du pc portable du réseau wifi, la vidéo saccade, comme si la vitesse de connexion était insuffisante…

je comprends pas pourquoi ça passe dans un sens et pas dans l’autre

si quelqu’un sait d’où ça peut venir…

je débute en soit avec le wifi donc j’ai peut-être loupé quelque chose

pour info le reseau wifi est en 54Mb et le filaire en 1Gb
et le portable oscille entre 95 et 100 % en réception wifi

merci de votre aide

Hello,

besoin de queleques précisions …

  • t’a des erreurs sur les interfaces de ton switch ? sur ton BSD ?
  • t’a vérifié les vitesses/duplex des ports ?
  • que donne les transferts LAN/LAN ? et Wifi/Wifi ?
  • est-ce que ça merde juste avec les vidéos ou aussi avec FTP/HTTP ?

A+
Fooc

[quote=“fouc, post:2, topic: 29841”]Hello,

besoin de queleques précisions …

  • t’a des erreurs sur les interfaces de ton switch ? sur ton BSD ?
  • t’a vérifié les vitesses/duplex des ports ?
  • que donne les transferts LAN/LAN ? et Wifi/Wifi ?
  • est-ce que ça merde juste avec les vidéos ou aussi avec FTP/HTTP ?

A+
Fooc[/quote]

Merci de ta réponse

j’ai pas vu d’erreur spécifique sur mon BSD
concernant le switch/hub lan, il n’y a pas d’interface de gestion…
les vitesses/duplex des ports de quel pc ?
les transfert LAN/LAN => aucun pb
les transfert wifi/wifi => j’ai un seul pc connecté en wifi derrière le routeur
le http => pas de problème que ça soit l’accès au net que l’accès à mes 2 serveurs web différents se trouvant sur 2 pc différents sur le lan.
ftp => pas testé

Tous

Sur le LAN je suis sûr qu’il sont bons…idem pour le routeur, le ifconfig de la carte wifi est bien en 11g

par contre le portable je sais plus… faudra que je vérifie ce soir…

mais même si la carte pcmcia du portable est mal configurée niveau vitesse, comment ça expliquerait qu’il y ait une telle différence dans un sens par rapport à l’autre ?

Quand c’est lent, ça concerne le portable? Quand tu écris sur le disque du portable? Ce serait pas tout bêtement un disque de portable très lent en écriture?

Edit: quoique non, si tu ne fais que la lire du réseau, c’est peut-être plutôt le disque de la machine source qui galère en lecture… Disque fragmenté?

[quote=“amans, post:3, topic: 29841”]Merci de ta réponse

j’ai pas vu d’erreur spécifique sur mon BSD
concernant le switch/hub lan, il n’y a pas d’interface de gestion…
les vitesses/duplex des ports de quel pc ?
les transfert LAN/LAN => aucun pb
les transfert wifi/wifi => j’ai un seul pc connecté en wifi derrière le routeur
le http => pas de problème que ça soit l’accès au net que l’accès à mes 2 serveurs web différents se trouvant sur 2 pc différents sur le lan.
ftp => pas testé[/quote]

Si tu récupère le fichier video via un browser, tu obtiens quoi comme débits ?
L’idée du D/L http/ftp, c’est de mettre en évidence le dysfonctionnement sur tout les protocoles. Du coup tu peux determiner si le pb sera plus réseau ou système.

L’assymétrie de transferts peut s’expliquer par une désychronisation de duplex. Un poste en full, l’autre en half.
En wifi (a/b/g), il n’y a pas le pb, c’est une bande partagée, donc half.

En fait, si tu veux t’en sortir, il faut que tu test toute la chaine. Le serveur héberge le fichier, il faudra faire les tests :

  • PC LAN upload/download vers le serveur (si qq chose deconne là, pb de switch ou de carte)
  • BSD ul/dl vers serveur (si pb là, vérifier carte du bsd à coup de mii-tool et ifconfig -a)
  • poste client WLAN ul/dl vers BSD (si pb là vérifier config wifi, désactiver WEP/WPA)

Tu peux faire des captures réseau avec Ethereal ou tcpdump, ça peut mettre en évidence des soucis …

Bref, bon courage, bon diag,

F

[quote=“fouc, post:7, topic: 29841”]Si tu récupère le fichier video via un browser, tu obtiens quoi comme débits ?
L’idée du D/L http/ftp, c’est de mettre en évidence le dysfonctionnement sur tout les protocoles. Du coup tu peux determiner si le pb sera plus réseau ou système.[/quote]
je viens de tester je DL à 100ko/s à peu près en prenant un film sur le lan à partir du WLAN

[quote=“fouc, post:7, topic: 29841”]L’assymétrie de transferts peut s’expliquer par une désychronisation de duplex. Un poste en full, l’autre en half.
En wifi (a/b/g), il n’y a pas le pb, c’est une bande partagée, donc half.[/quote]
je ne peux pas mettre mon 1Gb en half, j’ai donc testé en 100Mb half => idem toujours le même soucis

je suis en train de le faire

http://88.160.173.94:81/ethereal.cap
(j’espère que ça passe…pas encore testé l’accès au serveur de l’extérieur depuis mon déménagement B) )

voilà la capture pendant 20sec en lisant une vidéo (pendant les 10 dernières secondes environ) se trouvant sur le lan (192.168.0.1) à partir du wlan (192.168.200.1)

si tu avais le temps de jeter un coup d’oeil histoire de me dire ce que tu en penses…

merci

pour info… la config de la carte wifi sur le routeur openbsd

ral0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
lladdr 00:08:a1:9f:c9:e4
media: IEEE802.11 autoselect mode 11g hostap
status: active
ieee80211: nwid wilan chan 11 bssid 00:08:a1:9f:c9:e4 100dBm
inet 192.168.200.10 netmask 0xffffff00 broadcast 192.168.200.255
inet6 fe80::208:a1ff:fe9f:c9e4%ral0 prefixlen 64 scopeid 0x4

Le driver Ral sous OpenBSD est pas tip top. Il limite enormement la puissance (par rapport aux drivers linux et windows) ce qui réduit énormement la portée et les débits. (je sais de quoi je parle, j’ai du bouger mon serveur pour que mon frere le capte de sa chambre)

Ca peut venir de là.

Sinon 100ko/s pour de la video c’est pas assez pour une lecture sans saccade.