Mandriva et bureau 3D

Salutation a tous la zone!

Alors voici mon probleme:
Voulant débuter sous linux j’ai choisit de commencer sous Mandriva 2007 free, j’ai choisi cette distribution car elle présentait un gadget qui m’interressait : le bureau 3D.
Le seul probleme c’est que lorsque j’essaye de l’activer mandriva me signal que mon materiel n’est pas compatible. Cela m’a étonné car ma config est :

           P4 a 3ghz
           geforce 7800gt de chez msi
           1 go de ram en ddr2
           Carte mere gigabyte GA-8I915P

Vous en conviendrez que c’est pas une config trop mauvaise.
Donc mon probleme c’est comment puis je activer ce bureau 3D? faut t’il que j’installe des applications spéciales? et surtout comment dois je faires (commande etc…)?
Merci d’avance au Geek de tout bord pour leur aide.

Est ce que tu as installé les pilotes nvidia ? C’est avec le paquet “nvidia-kernel” il me semble. Ensuite tu dois modifier ton fichier /etc/X11/xorg.conf et remplacer la ligne “driver ‘nv’” par “driver ‘nvidia’”.

Après le bureau 3D… C’est un gadget. Ce qui est vraiment bien c’est Exposé B)

Je vais vérifier et je vous tien au courant.

Que je sache, on est même obligés d’aller sur le site nvidia pour ramener les drivers, non?
D’ailleurs, il est presque tout le temps nécessaire d’installer les sources du kernel avant.

Tant que t’as pas un splash screen “nvidia” au démarrage de X, c’est pas bon (ie: drivers compatibles mais vraiment pas optimisés).

Les pilotes “nv” de xorg, c’est pas qu’ils sont pas optimisés. C’est juste qu’ils ne gèrent absolument pas la 3d du tout et tout passe en software.

[quote=“Arthal, post:1, topic: 44508”]Cela m’a étonné car ma config est :

           P4 a 3ghz
           geforce 7800gt de chez msi
           1 go de ram en ddr2
           Carte mere gigabyte GA-8I915P

Vous en conviendrez que c’est pas une config trop mauvaise.[/quote]

pour faire tourner compiz (ce qui est activable par défaut sous mandriva je crois bien), une G4 suffit largement avec 512 de ddr et un P4 de 2ghz. Certains font tourner ca avec le simple chipset graphique intel de leur cm.

[quote=“vectra, post:4, topic: 44508”]Que je sache, on est même obligés d’aller sur le site nvidia pour ramener les drivers, non?
D’ailleurs, il est presque tout le temps nécessaire d’installer les sources du kernel avant.

Tant que t’as pas un splash screen “nvidia” au démarrage de X, c’est pas bon (ie: drivers compatibles mais vraiment pas optimisés).[/quote]

Les drivers sont ramenés par le mainteneur du paquet chez mandriva, c’est pareil chez gentoo. Et chez mandriva, par besoin de recompiler le noyau, “les ptits bouts qui manquent” B) sont livré avec le paquetage nvidia-kernel de chez mandriva. Enfin je crois.

Pour le splash “nvidia”, on peut le desactiver. B)

[quote=“Arthal, post:1, topic: 44508”]Salutation a tous la zone!

Alors voici mon probleme:
Voulant débuter sous linux j’ai choisit de commencer sous Mandriva 2007 free, j’ai choisi cette distribution car elle présentait un gadget qui m’interressait : le bureau 3D.
Le seul probleme c’est que lorsque j’essaye de l’activer mandriva me signal que mon materiel n’est pas compatible. Cela m’a étonné car ma config est :

           P4 a 3ghz
           geforce 7800gt de chez msi
           1 go de ram en ddr2
           Carte mere gigabyte GA-8I915P

Vous en conviendrez que c’est pas une config trop mauvaise.
Donc mon probleme c’est comment puis je activer ce bureau 3D? faut t’il que j’installe des applications spéciales? et surtout comment dois je faires (commande etc…)?
Merci d’avance au Geek de tout bord pour leur aide.[/quote]
La Mandriva 2007 free n’inclue pas par defaut les drivers nvidia proprietaire (mais ils le sont dans la version payante), qui sont necessaires pour le bureau 3D.

Une solution simple pour les installer est d’utiliser les packages de PLF, en allant sur ce site :
http://easyurpmi.zarb.org/
selectionne plf-free et plf-nonfree (tu peux en profiter pour rajouter main et contrib si tu en as marre de devoir inserer les CDs pour installer de nouveaux programmes) et copie les commandes qui sont données sur la page dans une console en root.

Ensuite installe le package nvidia à l’aide du gestionnaire de packages, ou en ligne de commande :

Après il ne reste plus qu’a aller dans le centre de controle pour activer le bureau 3D.

Déjà je pense qu’il faut bien configurer URPMI:
http://olivier.aurait.eu/urpmi/

Ensuite il doit suffire d’installer un simple paquet, de reconnecter la session, et c’est bon.
Sous Ubuntu pour avoir l’accélération 3D j’ai juste installé nvidia-kernel et nvidia-common je crois, truc du genre.

Il y a un sujet pas trop vieux sur Beryl (le bureau 3D) et Ubuntu dans le forum. Ca te sera peut être utile.

Bonne chance.

Ooops, j’ai zappé la réponse de BokLM. Désolé.

Re a tous ! aprés une semaine bien charger j’ai eu le temp d’essayer ce que BokLM m’a conseillé!
Mais voila dés que je lance la commande " urpmi nvidia " il m’affiche ce message qu’est ce que sa veut dire et comment y remedier :

Certains paquetages demandés ne peuvent pas être installés :
dkms-2.0.13-3mdv2007.0.noarch (en raison du manque de gcc-4.1.1-3mdk.x86_64)
dkms-nvidia-8774-4plf2007.0.i586 (en raison du manque de gcc-4.1.1-3mdk.x86_64)
gcc-4.1.1-3mdk.x86_64 (car libc.so.6(GLIBC_2.3.4)(64bit) est non satisfait)
kernel-source-2.6.17.5mdv-1-1mdv2007.0.x86_64 (en raison du manque de gcc-4.1.1-3mdk.x86_64)
nvidia-8774-4plf2007.0.i586 (en raison du manque de gcc-4.1.1-3mdk.x86_64)

[quote=“Arthal, post:10, topic: 44508”]Re a tous ! aprés une semaine bien charger j’ai eu le temp d’essayer ce que BokLM m’a conseillé!
Mais voila dés que je lance la commande " urpmi nvidia " il m’affiche ce message qu’est ce que sa veut dire et comment y remedier :

Certains paquetages demandés ne peuvent pas être installés :
dkms-2.0.13-3mdv2007.0.noarch (en raison du manque de gcc-4.1.1-3mdk.x86_64)
dkms-nvidia-8774-4plf2007.0.i586 (en raison du manque de gcc-4.1.1-3mdk.x86_64)
gcc-4.1.1-3mdk.x86_64 (car libc.so.6(GLIBC_2.3.4)(64bit) est non satisfait)
kernel-source-2.6.17.5mdv-1-1mdv2007.0.x86_64 (en raison du manque de gcc-4.1.1-3mdk.x86_64)
nvidia-8774-4plf2007.0.i586 (en raison du manque de gcc-4.1.1-3mdk.x86_64)[/quote]
Quelle version de Mandriva as tu installé ? i586 ou x86_64 ? (tu peux le voir en regardant dans le fichier /etc/mandriva-release)

Si tu es en i586, le problème vient du fait que tu as ajouté des sources x86_64.
Est ce que tu peux montrer le contenu du fichier /etc/urpmi/urpmi.cfg ?

alors dans le fichier mandriva-release il y a marqué:
Mandriva Linux release 2007.0 (Official) for x86_64

et dans le urpmi.cfg :

Installation\ DVD removable://mnt/cdrom2/x86_64/media/main64 {
hdlist: hdlist.Installation DVD.cz
key-ids: 70771ff3
removable: /dev/hdb
static
with_hdlist: media_info/hdlist.cz
}

Installation\ DVD\ (main32) removable://mnt/cdrom2/x86_64/media/main32 {
hdlist: hdlist.Installation DVD (main32).cz
key-ids: 70771ff3
removable: /dev/hdb
static
with_hdlist: media_info/hdlist.cz
}

main http://mirror.cricyt.edu.ar/MandrivaLinux/…ia/main/release {
hdlist: hdlist.main.cz
ignore
list: list.main
with_hdlist: media_info/hdlist.cz
}

main_updates ftp://mandrake.cict.fr/Mandrakelinux/offi...ia/main/updates {
hdlist: hdlist.main_updates.cz
key-ids: 22458a98
update
with_hdlist: media_info/hdlist.cz
}

contrib ftp://mandrake.cict.fr/Mandrakelinux/offi...contrib/release {
hdlist: hdlist.contrib.cz
key-ids: 78d019f5
with_hdlist: media_info/hdlist.cz
}

contrib_updates ftp://mandrake.cict.fr/Mandrakelinux/offi...contrib/updates {
hdlist: hdlist.contrib_updates.cz
key-ids: 26752624
update
with_hdlist: media_info/hdlist.cz
}

plf-free ftp://ftp.free.fr/pub/Distributions_Linux...ase/binary/i586 {
hdlist: hdlist.plf-free.cz
key-ids: caba22ae
with_hdlist: hdlist.cz
}

plf-nonfree ftp://ftp.free.fr/pub/Distributions_Linux...ase/binary/i586 {
hdlist: hdlist.plf-nonfree.cz
key-ids: caba22ae
with_hdlist: hdlist.cz
}

Ok, tu as donc une version x86_64, mais tu as rajouté les medias pour les packages i586.

Je te conseil donc de les retirer, en executant dans un shell root :

Puis de retourner sur http://easyurpmi.zarb.org/ pour rajouter les meme medias (main main_updates contrib contrib_updates plf-free plf-nonfree) mais en selectionnant x86_64 pour l’architecture.

Après avoir fait ca, le “urpmi nvidia” devrait marcher.

alors j’ai désinstallé avec la commande que tu m’a donné, mais maintenant lorsque je fais urpmi nvidia il me met " pas de paquetage nommé nvidia "

Et tu as reinstallé en allant sur http://easyurpmi.zarb.org/ et en selectionnant bien x86_64 ?

oui j’ai désinstallé avec ta commande j’ai réinstallé avec les commande du site que tu m’a passé et maintenant avec urpmi nvidia sa me met " pas de paquetage nommé nvidia "

Est ce que tu peux faire voir le contenu du fichier /etc/urpmi/urpmi.cfg ?

Désolé !!! je me suis viandé en copiant les ligne de code maintenant urpmi nvidia marche mais il me demande de faire un choix entre plusieur paquetage. Lequel dois-je prendre ?

Il demande de choisir entre quoi et quoi ?

Sinon, au hasard B)

bon alors aprés avoir selectionner un paquet au hasard, il s’est installé sans probleme, et la je redemarre parce que j’ai besoin de retourner vite fais sous windows. C’est alors que j’ai eu un magnifique NTLDR manquant auquel un fixmbr et un fixboot n’ont rien^pu faire. Résultat des course je suis bon pour réinstaller et windows ET mandriva … B) je suis blazé. Mon aventure s’arrete la je sais meme pas si je vais réinstaller mandriva pour l’instant je m’arrete la. Merci comme meme d’avoir passé du temp pour m’aider… bonne soiré a tous