[Nux] du son, mais pas trop

hello les ninuxiens,

voilà mon probleme : sur ma debian (etch), j’ai du son seulement si je lance les programmes en root, j’ai donc chmodé /dev/dsp - ln vers dsp0 :s - et dsp0, mais rien.
j’ai un peu cherché mais rien de formel.

A coté de ça, avant ma réinstall j’avais réussis à avoir du son multi threadé (ie je pouvais jouer deux sources sonores en meme temps), et là plus.
ya -t- il une astuce ?

n’hesitez pas à dire qu’il manque des infos, comme la version d’alsa … (que j’arrive pas à trouver).

Merci d’avance pour vos idées B)

Les utilisateurs normaux ont le droit d’écrire dans les périphériques sonores de /dev ?

Truc tout con : il n’y a pas un groupe “audio” dont ton user ne ferait pas partie ?

Tu as peut-être aussi besoin d’être dans le groupe wheel.

On en revient au même problème de droits. D’une manière générale, si ton utilisateur n’a pas le droit d’écrire dans les fichiers périphériques correspondant à ce qui balance du son, tu ne pourras pas en avoir et ça explique pourquoi root le peut. Logique, pour sortir quelque chose, il faut d’une certaine manière écrire quelque part ce que tu sors, fut-ce du son. Comme tu peux le voir, il y a plusieurs manières de régler le problème, si tant est soit-il que ça vienne bien de là.
J’ai toujours trouvé un peu idiot que ce genre de chose ne soit pas déjà bien réglée dès l’installation, mais ça fait partie des petites bizarreries de Linux, surtout quand la distribution s’appelle Debian ou Slackware.

merci a vous !
pour les problemes de groupes, je regarde demain car euh … […]
mais je pensait résoudre ça avec un chmod 777 sur /dev/truc, ça donne pas le droit en ecriture sur le perif ? (oui c’est bourrin mais ça me semble « correct »)
bref voir demain quoi : )

et pour le multi-thread une idée ? B)"

edit: trop de smileys :smiley: ( ← oui oui je sais (rah j’allais en remettre un ici (et encore un là)))
edit 2: piti bug : le smiley : - ) affiche un : - " (pleins d’espaces pour pas qu’ils soient interprétés)

Oui. Il faut un serveur de son type esound ou artdsp, mais j’ai jamais reussi a les faire marcher (bon j’ai pas trop chercher non plus).
Faudra que je m’y penche parce que c’est chiant quand on a youtube et xmms en meme temps.

LoneWolf
’verrais plus tard, pas urgent ca.

Je crois que la dernier version de ALSA le genre comme un grand !

Koubiak

vouip. Alsa c’est bieng, ça gère les accès concurrents aux periphs de son tout seul, comme un grand B)

Alsa c’est trop cool, esound rajoute une surcouche, c’est pas top.

oui, les multiplexeurs “soft” ou serveurs de son sous Linux étaient tout-à-fait justifiés à l’époque d’OSS et que celui-là ne gérait pas le sound multiplexing. D’ailleurs, il me semble avoir vu que pour KDE4, arts va passer aux chiottes (pas de souces et pas le temps de chercher). Par contre, il faut que le driver ALSA de ta carte son (et ta carte son) supporte le sound multiplexing. Si vraiment ce n’est pas le cas là un serveur de son (esd pour Gnome ou arts pour KDE) s’imposera, et moi j’ai jamais eu de problèmes avec.

Sinon, pour le problème de droits, bien sûr que le chmod va résoudre le problème, mais c’est moche, parce qu’au prochain boot, t’auras plus les droits. Par contre, il y a (sur toutes le distros que je connnais) un groupe audio qui lui a les permissions sur les différents périphs. Si tu ajoutes ton user au groupe audio, tu les auras tout le temps, et là c’est propre (et prévu pour, tsss tsss)

comme un grand? ah oui? ah bon.
J’ai jamais reussi a faire tourner mozilla (ie flash) et xmms en meme temps. Si quelqu’un a une solution miracle, je prends (j’utilise alsa sur tous mes systemes)

edit: j’ai fait un coup de google et j’ai choppe ca: C’est mieux. J’ai plus besoin d’arreter moz, d’arreter xmms, pour relancer moz et ecouter youtube. Maintenant, j’ai juste a arreter xmms et lancer youtube et ca roule. Puis virer la page youtube et faire play sur xmms et c’est bon.
Mais c’est toujours pas simultane.

edit2: 2.6.8 (debian stock kernel), alsa 1.0.8-4

LoneWolf
Les mysteres de la musique.

C est quoi ta version de kernel ?

Je sais que c est dans une des dernieres revisions que ALSA implante cette option. Que je n ai moi meme jamais usé, car plus trop sous nux en ce moment.

Koubiak

j’ai un 2.6.16.20 compilé maison, et sur l’install précédente c’était le meme .config pour le kernel, donc ça devrait rouler.
pour le son > le chmod a rien arrangé, je teste les groupes de suite.