Remplacer un DLL qui déconne sous Vista

Hello la Zone :crying:

Depuis deux semaines je me traîne un problème de DLL sous Vista particulièrement chiant:

Lorsque je surfe sous Chrome (mais que j’utilise aussi pour G. presque en permanance avec le mode fenêtré - sans tabs - très sympa) est apparu soudainement le message d’erreur du DLL SensApi.dll, que je vous présente:


Bonjour c’est moi et je reviens te faire chier (avec mes potes)

D’un, il n’apparaît pas qu’une fois mais plusieurs (3 fois en général mais parfois sept fois) de façon aléatoire ; il ne fait pas planter Chrome mais c’est juste ennuyant. De deux, et c’est le plus chiant : il empêche certains programmes de se lancer comme Messenger (l’image ci-dessus le concerne). Et j’en ai vraiment besoin :cry:

D’après les infos que j’ai, ce DLL est relié à la gestion des appareils mobiles : je n’en ai aucun.

Représailles employées:

  • Le scan complet du système par un antivirus, Adware, Spy bot n’ont rien trouvé.
  • Changement à la bourrin (en mode sans échec également) du DLL avec une version compatible trouvée sur Internet : ne marche pas.
  • Réinstallation ciblée de Vista : je ne peux pas, j’ai un portable Dell et le CD de restauration veut TOUT restaurer.

Bref, je cherche des solutions.

Merci d’avance pour les propositions :slight_smile:

Bon j’ai rien dit XD.

Erm tu as fait les updates microsoft ?
Essaye de réinstalle Msn / Chrome non ?

Sur le net j’ai trouvé çà :
Start … Run … sfc /scannow

Tu peux toujours downloader le DLL ici et tenter de le remplacer.

Edit: Autant pour moi, je n’avais pas lu l’avant derniere ligne…

“- Changement à la bourrin (en mode sans échec également) du DLL avec une version compatible trouvée sur Internet : ne marche pas.”

Chrome est toujours en beta ? peut-être que la version 2 arrange les choses

Essaye en virant la dll, ou en cherchant dans autoruns si ya une ligne qui en parle, si oui, revient avec la categorie que tu donnes autoruns (je pressent bien une dll de merde, ou une clé dans le registre qui fait lancer cette dll moisie en lieu et place d’une autre)

recherche dans la BDD comme le dit ana

sous FF aucun pblm ?

desactives les services de synchro des periph mobiles ?
(sync center et autres amuses-gueule)

Merci pour les réponses :slight_smile: Je reprends par ordre des messages:

  • Vista (SP1) est à jour. J’ai bien sûr réinstallé ce qui déconnait avec ce DLL mais rien n’a changé. La commande sfc /scannow ne… fait rien de particulier

  • Je ne peux pas virer le DLL directement (c’était implicite dans le premier message : je n’ai pas réussi à le remplacer donc la suppression ne peut marcher)

  • J’ai installé et testé Autoruns mais le DLL en question n’est pas mentionné!

  • Recherche dans la base de registre : Je l’ai rencontré plusieurs fois mais je ne touche pas, je n’y connais absolument rien. Je peux noter toutes les occurrences si ça peut aider à résoudre le problème.

  • Désactivé Sync Center mais ça ne change rien. Bonjour est désinstallé (on sait jamais)

Maintenant que j’y pense, ça coïncide à peu près au moment où j’ai eu mon iPod. Le message d’erreur apparaît pourtant qu’il soit branché ou non.

Saloperie de DLL :confused:

[edit] Il n’apparaît qu’une fois dans la BDR:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide\DerivedData\Components\x86_microsoft-windows-sens-client_31bf3856ad364e35_6.0.6000.16386_none_ff0beccac0362b51\f!sensapi.dll

Tu as essayé
Start … Run … sfc /scannow

Essaye de désinstall tout ce qui a rapport avec ton ipod non ?
Panneau de Config → Centre de synchronisation ?
Vire le partenariat :slight_smile:

Des personnes qui ont des bugs avec le sidebyside installent çà :
http://www.microsoft.com/downloads/details…;displaylang=en

Rien a perdre j’ai dit ? ou je l’ai pensé fort XD

[quote=“Beasty, post:9, topic: 48937”]Tu as essayé
Start … Run … sfc /scannow[/quote]

[quote=“Beasty, post:9, topic: 48937”]Essaye de désinstall tout ce qui a rapport avec ton ipod non ?
Panneau de Config -> Centre de synchronisation ?
Vire le partenariat :)[/quote]

Rien d’installé dans certte partie, donc rien à enlever!

[quote=“Beasty, post:9, topic: 48937”]Des personnes qui ont des bugs avec le sidebyside installent çà :
http://www.microsoft.com/downloads/details…;displaylang=en

Rien a perdre j’ai dit ? ou je l’ai pensé fort XD[/quote]

Installé mais ça ne change rien.

L’erreur apparaît aussi en utilisant iTunes (le nom est différent sensapi.dll sans les majuscules; ça ne change pas grand chose!) et sous Chrome le pop-up surgit une dizaine de fois sur certaines pages.

J’ai beau fouillé je ne vois pas d’où ça vient.

Je te dirais bien de passer a la vitesse superieure avec Process Monitor, mais ca risque de devenir vraiment compliqué apres. Mais si tu as les connaissances pour utiliser et analyser un peu un log PM, ca se tente.

Nan je n’y connais rien mais je sens que je vais devoir y passer.

Je me renseigne sur le logiciel.

Ce qui me surprend c’est que je ne retrouve pas de traces du même problème sur le net. Vista avait été plutôt calme niveau bug mais là il me casse les joyeuses.

[edit] Faute

J’ai trifouillé avec Process Monitor mais les seules occurences qui apparaissent concernant le DLL en question ne renvoient à rien de particulier. Genre “Je vais le chercher, ça plante”. Point.

Je maîtrise sûrement mal le logiciel donc si quelqu’un veut les logs (ça défile à une vitesse incroyable il est bienvenue.

Devant ces échecs répétés, il me reste une seule solution. Je n’ai pas voulu l’utiliser au départ mais je suis au pied du mur…

SUMMON GloP ! \●/ (yes he can… I hope so)