[RESOLU]Lecture d'un h264 qui saccade

Voilà : il y a quelques temps, j’ai téléchargé le teaser de spiderman3 en 720p, mais j’avais encore mon vieux barton qui crachait ses poumons avec. J’ai donc gardé le fichier, en me disant que je pourrais le regarder dans de bonnes conditions quand j’aurai mon C2D.
Maintenant j’ai changé de config depuis quelques temps, et une des premières choses que j’ai faite a été de visualiser ce fichier. Et effectivement, aucun problème avec le C2D, c’est fluide, je peux faire autre chose en même temps (même pas 20% d’occupé sur chaque core ). Bref, tout va bien B).

C’est là que vous vous demandez « mais pourquoi il écrit ici si tout va bien ?? »
MAIS (ben oui, y’a un « mais »), je viens de relancer le fichier en question (Je suis retombé dessus en faisant le tri), et ça saccade (voire même le son continue mais pas l’image !!. Je n’ai rien changé à ma config entre temps, je ne vois pas pourquoi il ne tournerait plus maintenant.

Premier réflexe : regarder l’occupation cpu. Et là surprise, il n’a pas l’air très occupé, 1 ou 2% seulement !
Speedstep: activé mais fonctionne, je le désactive quand même le temps du test.
Je change la priorité de mpc, et même en realtime, rien à faire. Je change aussi l’affinité cpu au cas où, pas de résultat non plus.
J’utilise le TLCP avec mpc, mais je teste avec quicktime (le fichier est un .mov) : même problème, sauf que de temps en temps, il me balance « Microsoft visual runtime C++ " Buffer overrun » avant de se fermer.
Là je me dit : bon, le ffdshow date un peu, et même s’il suffisait pour lire ce fichier il y a quelques semaines, je vais essayer d’en installer une version plus récente.
Ca n’a rien changé.
Aucun processus anormal et hijackthis OK.

Je teste avec VLC : Ooh miracle! Lecture très fluide, occupation cpu normale. Bref ça roule comme ça devrait.

Donc voilà, vlc c’est bien, mais je voudrais garder mpc pour tout, et surtout savoir d’où vient ce problème.
Donc j’en appelle à la zone, si douée pour résoudre ce genre de soucis :smiley:

edit :
résolu en changeant l’extension du fichier en .mp4!
merci C_wiz B)

UN SALE CODEC ! Regarde quel codec tu utilises (clic droit filters, fait nous la liste de ce qui ressemble a de la video). Google -> ffdshow-tryout sinon (mais faut virer les codecs cacas).

Effectivement j’ai du installer xvid et divx pour de l’encodage, mais j’ai désactivé le décodage (ffdshow fonctionne bien avec d’autres vidéos .)

Sinon pour le menu filter : il est grisé. Effectivement c’est bizarre, et je n’ai aucune icône ffdshow dans le systray. Comment “rétablir” ffdshow? Sachant que ca fait 2 fois que je le réinstalle en réinitialisant les paramètres ?

edit : dernière release de ffdshow_tryout installé, idem.

Ha quand même. Et avec un MPC tout neuf ?

Quand on désinstalle TLCP, ça désinstalle pas mpc aussi ? Je vais réessayer manuellement quand même au cas où.

Vire TLCP, de toute facon il est hyper outdaté. Installe ce mpc là : http://tibrium.neuf.fr/

Donc plus de TLCP du tout, juste ffdshow tryout+ mpc homecinema ?

edit: même problème de toute manière.

Mais de toute façon ca marchait très bien avant, avec le « vieux » TLCP ! argh :confused:

Oui.

Le problème persiste.
Doit bien y avoir quelque chose qui a déclenché ça.

[quote=“astrojojo, post:9, topic: 34852”]Le problème persiste.
Doit bien y avoir quelque chose qui a déclenché ça.[/quote]
Options > Internal filters, tu décoches tout a gauche et a droite

External filters, reset list en bas

Le menu filters est entre Favorites et Shaders dans un right click dans une video qui se joue (oui, j’aurai du commencer par là peut être…).

Toujours le même problème.
Mais dans “External filters”, il n’y a rien, tout était vide/grisé.

[quote=“astrojojo, post:11, topic: 34852”]Toujours le même problème.
Mais dans “External filters”, il n’y a rien, tout était vide/grisé.[/quote]
Tu lis bien une vidéo quand tu fais ton clic droit ?

Oui oui B). Et le menu filter n’est pas grisé sur une autre vidéo. Mais sur celle là, si !

Ha, on avance. Pareil dans Play > Filters j’imagine. L’extension du fichier c’est quoi sinon ?

(voir un lien direct vers ton trailer)

oui, pareil pour play>filter.
Le fichier est un mov (comme dit dans le 1er post B) ). 300 Mo, plus dispo en téléchargement. Je peux éventuellement l’héberger mais ca va prendre “quelques” minutes.

[quote=“astrojojo, post:15, topic: 34852”]oui, pareil pour play>filter.
Le fichier est un mov (comme dit dans le 1er post B) ). 300 Mo, plus dispo en téléchargement. Je peux éventuellement l’héberger mais ca va prendre “quelques” minutes.[/quote]
Je vais chercher un trailer en attendant.

Je le met , mais y’en a pour 45 minutes d’upload (–> jusqu’à 1h25)

edit: à première vue c’est lu correctement dans firefox O_o.

Speedstep c’est pas quand le proco change de fréquence tout seul selon ce qu’il fait? Si oui, comment t’as fait pour le virer?

Si c’est ça. pour le virer 2 solution.

  1. le désactiver dans le bios.
  2. aller dans les options d’alimentation du pc et le régler en pc de bureau (gestion d’alimentaiton minimale, portable&co l’activent)

[quote=“astrojojo, post:19, topic: 34852”]Si c’est ça. pour le virer 2 solution.

  1. le désactiver dans le bios.
  2. aller dans les options d’alimentation du pc et le régler en pc de bureau (gestion d’alimentaiton minimale, portable&co l’activent)[/quote]
  3. http://cpu.rightmark.org/products/rmclock.shtml

Sinon je viens d’essayer avec le trailer de transformers (mov h264), ca lit très bien avec que mpchc+ffdshow-tryouts. En utilisant ffdshow video pour décoder. A froid j’ai 23 pistes a te proposer :

  • dans les External filters, add, ffdshow video. Puis prefer (a droite).

Si ca ne fait rien, ca peut être le splitter. Downloader ca : http://haali.cs.msu.ru/mkv/MatroskaSplitter.exe En sachant que je ne l’ai pas sur ma machine sur laquelle se lit transformers.

  • Troisième piste, j’aurai du y penser avant : renomme en .mp4. Je sais ça parait bête…