Spécifier une interface pour l'accès au net

Bonjour,

J’ai un petit soucis tout bête. Je suis connecté en Wifi à la livebox d’un pote, qui est en collocation avec moi. J’ai le net, jusque là tout est très simple, tout va bien. L’interface wifi est en 192.168.1.200, avec la passerelle en 192.168.1.1.

Maintenant, je voudrais mettre un deuxième poste. Le signal Wifi étant relativement faible, je compte donc relier le deuxième pc par câble. Voila donc la carte Ethernet du pc relié au net par le wifi qui se voit offrir l’adresse 10.0.0.1, et le deuxième pc 10.0.0.2, avec 10.0.0.1 en passerelle.

Le problème, c’est que dès que j’active l’interface Ethernet sur le pc qui est relié à la livebox, je n’ai plus le net. En fait, on dirait qu’il essaye de se connecter sur l’interface filaire, qui évidement n’est pas relié au net.

J’ai un pare feu à la con, avec comme zone sûre le réseau privé Ethernet, et comme zone sécurisée la liaison wifi jusqu’à la livebox (pour éviter que mon pote ne renifle tout avec un wireshark :crying: )

Une idée peut être? je ne vois pas comment spécifier d’interface de connexion dans les options internet. Le poste en wifi est sous XP sp2, l’autre vista SP1.

Merci d’avance de vos ptits tuyeaux :slight_smile:

@ plus tard

Hum, moi je dirais que ton adressage n’est pas bon du tout.

La livebox est en 192.168.1.X
donc tout ton reseau doit avoir un adressage 192.168.1.x .
Donc change l’adresse ip.

Puis avec le pc tu peux partager la connexion internet, en faisant clic droit partager.
Normalement le pc filaire devrait avoir le net.

@edit: en espérant avoir compris ce que tu veux faire. Sinon tu peux jouer avec le routage:
add route

c’est la que tu peux spécifier l’interface à utiliser.

En fait le problème c’est que dès que je monte l’interface filaire ethernet sur le pc relié en wifi à la livebox, elle perds le net (elle doit chercher sur la mauvaise interface). Je voudrais donc forcer la machine à accèder au net via l’interface Wifi. :stuck_out_tongue:

Tu vois ce que je veux dire? :slight_smile: :crying: :cry:

n’utilise pas le dhcp.
Fou une adresse fixe.

mais normalement, tu n’as pas besoin de faire quelque chose, tu peux etre tres bien connecté en wifi sur ta livebox et en filaire sur la livebox.

[quote=« doomulation, post:1, topic: 47623 »]Bonjour,

J’ai un petit soucis tout bête. Je suis connecté en Wifi à la livebox d’un pote, qui est en collocation avec moi. J’ai le net, jusque là tout est très simple, tout va bien. L’interface wifi est en 192.168.1.200, avec la passerelle en 192.168.1.1.

Maintenant, je voudrais mettre un deuxième poste. Le signal Wifi étant relativement faible, je compte donc relier le deuxième pc par câble. Voila donc la carte Ethernet du pc relié au net par le wifi qui se voit offrir l’adresse 10.0.0.1, et le deuxième pc 10.0.0.2, avec 10.0.0.1 en passerelle.

Le problème, c’est que dès que j’active l’interface Ethernet sur le pc qui est relié à la livebox, je n’ai plus le net. En fait, on dirait qu’il essaye de se connecter sur l’interface filaire, qui évidement n’est pas relié au net.

J’ai un pare feu à la con, avec comme zone sûre le réseau privé Ethernet, et comme zone sécurisée la liaison wifi jusqu’à la livebox (pour éviter que mon pote ne renifle tout avec un wireshark :crying: )

Une idée peut être? je ne vois pas comment spécifier d’interface de connexion dans les options internet. Le poste en wifi est sous XP sp2, l’autre vista SP1.

Merci d’avance de vos ptits tuyeaux :slight_smile:

@ plus tard[/quote]

L’interface à utiliser pour sortir correspond à celle qui a une passerelle. Si tes 2 interfaces ont une passerelle, alors c’est celle qui est activée en dernier qui ‹ prend la main ›. Vérifie donc que t’as pas configuré de passerelle pour ton interface filaire.

En effet en filaire j’ai configuré la passerelle sur 10.0.0.1 (lui même). Cela pourrait donc venir de là? Je vais tester ca ce soir :crying:

Merci :slight_smile:

@ Silka: non il n’y a pas de DHCP, cela marrangerait que le pc passerelle qui a l’interface wifi et filaire le fasse sur le filaire d’ailleurs, comme ca je n’aurais pas à changer l’adressage ip du pc connecté à l’autre bout du fil à chaque fois (ce pc me sert pour mon boulot, et chez moi le soir).

Oui, ça vient de là.

Bien vu, c’était ça. C’est la passerelle configurée en dernier qui prend la main.

Maintenant lorsque je connecte en filaire le deuxième pc, le premier garde le net sans soucis, et ca ping.

Reste plus qu’à rajouter une route pour avoir le net sur le deuxième pc. Jvous tient au courant :slight_smile: , et merci !

[quote=« doomulation, post:8, topic: 47623 »]Bien vu, c’était ça. C’est la passerelle configurée en dernier qui prend la main.

Maintenant lorsque je connecte en filaire le deuxième pc, le premier garde le net sans soucis, et ca ping.

Reste plus qu’à rajouter une route pour avoir le net sur le deuxième pc. Jvous tient au courant :slight_smile: , et merci ![/quote]
Ton premier PC doit avoir le routage actif (paramètre dans le registre).
Dans ta livebox, ajoute une route du genre « 10.0.0.0 255.0.0.0 192.168.1.200 »

Ya pas moyen de faire autrement, sans toucher à la config de la livebox? je compter installer un ptit proxy sur mon premier pc en wifi…

Désolé pour la réponse tardive.
Tu peux effectivement utiliser un proxy, ou même “partager” la connexion wifi. Mais dans tout les cas, tu perdras des services.
Le proxy est limité à un certain nombre de services gérés. Le partage fait du NAT (derrière la livebox qui est déja un NAT)… et certaines applis gèrent pas forcément tip top).