TV DLNA qui trouve pas les vidéos sur le NAS

Hoyo la foule.

Bon j’ai besoin de vos lumières car j’aimerai comprendre pourquoi ça marche des fois et à d’autres pas.
Je précise que je suis pas ingénieur informaticien ni même admin réseau.
Mes connaissances je les ai acquises par la pratique et mes lectures donc c’est possible que j’ai des bouts de puzzle qui manquent :slight_smile:

Matos:

Tv: LG 55UH615V
NAS: DLINK Share center DNS-320 L (oui je sais c’est pas top et lent mais c’est pas ça qui pose problème)

Box Numéricable en Fibre 1Gb/s
Routeur TP-LINK Archer V2

But:
Faire en sorte que la TV et son lecteur interne aille piocher directement sur le NAS (pas de Plex ou autre).
Normalement en DLNA ça doit fonctionner (dites moi si je me trompe)

Config réseau:

Pour moi c’est là que ça pèche.

La box numéricable est en 192.168.0.1 en mode Routeur et avec le DHCP d’activé.
Si je comprends bien ce langage de barbare, ça veut dire que La box distribue les IP automatiquement.
ça veut dire aussi que c’est la passerelle vers Internet. Enfin disons plutôt qu’elle fait ça aussi.

Le routeur TP-LINK est en 192.168.1.1.
Le DHCP est aussi activé.

Je me dis que ça doit pas être top tout ça car en fait, si je comprends bien, la box distribue des IP en 192.168.0.xxx et le TP-LINK des IP en 192.168.1.2 ->192.168.1.200.

A chaque fois que j’ai voulu faire en sorte que mon TP-LINK se démerde seul à faire du DHCP ça a merdé et j’ai arrêté l’expérience parce que comme ça ça fonctionne.

Mais là j’ai du temps aujourd’hui et je veux faire un truc propre et stable et surtout je veux COMPRENDRE ! :slight_smile:

Dernière info:
La Tv est reliée par cable à la Box, puis un cable part de la Box pour arriver au TP-LINK et enfin un dernier cable part du TP-LINK pour arriver au NAS (oui un schéma c’est mieux mais je suis pas doué en dessin).

Dernière Minute:
Quand je relis la TV sur le Wifi du TP-LINK, j’arrive à lire direct sur le NAS (d’ailleurs c’est pour ça que j’avais réussi à faire marcher empiriquement le truc sans trop savoir pourquoi).
Je sais pas si les débits seront suffisants pour de la HD et/ou de la 4K donc je me dis naïvement que en filaire ce sera mieux.

Du coup voili voilou, merci de m’avoir lu jusqu’ici et de m’apporter vos lumières geekesques pour faire un reseau tout joli tout performant ^^

Donc tu as ça :

En effet, si ton NAS et ta télé ne sont pas sur le même réseau , ça peut pas marcher .
Mais a quoi te sert ton routeur ?

1 J'aime

Yep c’est ça.
Merci pour le schéma @mono

Le routeur me sert à avoir du Wifi 5G avec une meilleure norme, à avoir plus de ports RJ45 idéalement placés (pour les imprimantes sous le bureau par exemple).

Ceux de la box servent pour les consoles.

Pour plus de facilité je dirai que tu dois brancher tout ton matos sur le routeur ainsi tu restes sur un seul range ip. Et si tu n’as pas assez de ports tu peux rajouter un switch.

Dans l’idéal, j’aimerai ne pas avoir à racheter de matos et faire avec l’existant.
Déjà que tu m’as fais acheter un volant qui prend la poussière :stuck_out_tongue:

1 J'aime

je pense que si tu désactives le dhcp sur ton routeur, et garder que celle de la box ça devrait marcher , non ?

Cela dit, @cedric a raison, dans l’absolu, le plus simple de juste tout brancher sur le routeur => ça fonctionnerait « tout seul ».
Sinon tu peux tenter la suggestion de @mono mais je n’y crois pas trop sans intervention supplémentaire.
Peut être sera t il possible et nécessaire de forcer l’ip du NAS sur la même plage avec par exemple un 192.168.0.42 et masque de sous réseau 255.255.255.0 et en passerelle l’ip du TP-Link, voire celle de la box ?

Mais vu que c’est un routeur, je suis pas sur que ça soit une bonne idée ?

Tu fixes l’ip de ton routeur wifi et de ton NAS sur le même sous réseau que ta box (192.168.0.*) et tu désactives le serveur DHCP de ton routeur wifi. Ca fonctionnera.

1 J'aime

C’est tombé en marche, on touche a rien.
en vrai, ca marche pas hein :wink:

Anyhow, essaye de trouver le mode bridge dans ton routeur. Ça réglera le problème, t’auras un wifi « mieux » et ca sera la box sfr qui gérera le dhcp pour toutes les devices.

Comme dit plus haut, tes equipements sont sur 2 reseaux differents. Pourquoi tu mets pas tout sur 192.168.0.x ?

1 J'aime

je pense que c’est ce que veut dire Loewolf avec le mode bridge

Oui mais j’ai pas assez de port RJ45. Comme je l’ai dis @mono :slight_smile:

Alors ouai j’ai fais ça déjà: j’ai fixer l’ip du Nas en 192.168.1.27

Là je pense qu’on touche à ce que je veux.
Du coup tous mes devices connectés vont avoir une ip en 192.168.0.xxx ?
Et je pense que c’est dans ce sens là qu’il faut aller car je peux mettre le modem sfr en 192.168.1.xxx au lieu de 192.168.0.xxx mais par contre je peux pas faire ça pour les ip de départ et de fin.

ça s’appelle la sérendipité et ça a été vachement utile en sciences pour ta gouverne :stuck_out_tongue:

Pourquoi ça fait un Wifi « mieux » ?
(j’ai jamais compris dans le détails ce que fait un mode bridge. En français dans le texte :slight_smile: )

On va faire simple.

  • Ne touche pas a la box SFR
  • Cherche dans la doc et/ou l’interface d’admin de ton routeur le mode bridge if any
  • Si tu ne trouve pas le mode bridge, envoie un lien qui pointe sur le manuel de ton routeur. J’ai rien trouvé de pertinent sur le site de tp link avec la ref Archer C2 AC750.
  • C’est toi qui a affirmé que le wifi du routeur était mieux que celui de la box, d’où wifi mieux.

Pas trouvé…

C’est la V5 mais ça reste proche de la V2 (pas trouvé non plus la V2)

Oui. Enfin je crois. J’ai changé de Box récemment et ça se trouve le Wifi de la Box est maintenant aussi bien que celui du Routeur Archer :slight_smile:
Mais c’est plus facile de se connecter sur mon Archer grâce à un Pin que je connais

Ok donc je vais admettre que, sur le routeur archer, tu as besoin de 4 ports réseau et pas cinq. Comme le routeur n’a pas de mode bridge, c’est compliqué d’utiliser le port WAN de l’appareil. Attention, avec cette méthode, il ne sera pas possible de mettre a jour automatiquement le routeur archer (s’il est capable de le faire), il faudra installer le nouveau firmware a la main.

Configuration:

  • Ne pas toucher a la box SFR
  • Si nécessaire, changer les IPs des devices présentes sur le réseau du routeur Archer (NAS notamment, PC s’il n’est pas en DHCP). Si tu mets des IP fixes, penses a les mettre hors range DHCP de la box SFR (entre 10 et 50 visiblement)
  • Changer l’IP du routeur Archer (page 21, section 4.2.2) avec l’IP 192.168.0.2 et le sous réseau 255.255.255.0.
  • Relier la box SFR et le routeur archer sur un des ports réseau JAUNE. Le bleu devient inutilisable.
  • Se connecter sur le routeur archer (via 192.168.0.2 désormais) et désactiver le serveur DHCP (page 32, section 4.6.1)
  • Vérifier que l’ajout d’une nouvelle device reçoit bien une IP en 192.168.0.XXX
    • En filaire
    • En Wifi. Ça devrait fonctionner en wifi, si c’est pas le cas, il faut regarder les différentes options du routeur qui pourrait bloquer.

It should work.

Pour information l’UPnP ne peut être routé. Il ne fonctionne que sur un seul réseau.
Le Dlna utilise l’UPnP.

La solution de @LoneWolf est la plus efficace.

1 J'aime

Merci beaucoup pour le étape par étape !
Tout marche bien.

J’ai eu un petit souçi car j’avais fixé l’ip du NAS à la fois dans l’interface du NAS et celle du Archer :stuck_out_tongue:

1 J'aime