[Vista] Sacred

Bonjour
Voila, 3 ans apres sa sortie, je me suis décidé à lancer Sacred. J’ai l’édition Sacred Plus que j’avais acheté depuis presque 1 an et qui trainait toujours sur mon étagère.
Maintenant, avec un PC neuf, je me suis dit que les bugs de ralentissement que j’avais lu à droite à gauche serait oublié.

Malheureusement, le jeu ne se lance pas. Après la vérification du CD, l’ecran devient noir et j’ai l’erreur “Sacred a cessé de fonctionner”

Je suis sur Vista.

Windows me dit qu’il va chercher une solution, mais elle doit etre tout au fond de la cave car il ne revient jamais.

Bref! Pour ceux qui ont migré vers Vista, avez vous testé Sacred ?

PS: Drivers Video à jour, dernier patch appliqué, Tous les modes de compatibilité essayé, connecté en administrateur.

Bon, ben c’est pas la peine

Apres avoir parcouru le forum officiel, le jeu ne fonctionne pas sous Vista et il n’est pas prévu de faire un patch B)

bon, ben 20€ de perdu B)

[quote=“oevesque, post:2, topic: 45638”]Bon, ben c’est pas la peine

Apres avoir parcouru le forum officiel, le jeu ne fonctionne pas sous Vista et il n’est pas prévu de faire un patch B)

bon, ben 20€ de perdu B)[/quote]c’est plus que honteux, c’est scandaleux…
limite tu devrais envoyer la facture du jeu à Microsoft

[quote=“Ghadzoeux, post:3, topic: 45638”]c’est plus que honteux, c’est scandaleux…
limite tu devrais envoyer la facture du jeu à Microsoft[/quote]

Bah, c’est pas nouveau…
Je me souviens de Metal gear solid qui plante à quelques minutes de la fin sous windows XP… et c’est une adaptation microsoft ^^

Ma foi, autant rajouter, dans un autre genre de jeu

  • Teletubbies
  • Fisher Price et la vallée des CowBoys
  • Graine de génie, J’apprends à lire
  • Les champignons comestibles et leur confusion
    Qui eux, ont la délicatesse de ne meme pas s’installer sous Vista…

Mais bon, eux ils sont “vieux”.

oui enfin là meme si j’aime pas vista, c’est les programmeurs du jeux qui ne font rien pour arranger les choses, restons calme les gars.

(oui oui c’est bien baphomet qui a ecrit ça…)

[quote=“Baphomet, post:6, topic: 45638”]oui enfin là meme si j’aime pas vista, c’est les programmeurs du jeux qui ne font rien pour arranger les choses, restons calme les gars.

(oui oui c’est bien baphomet qui a ecrit ça…)[/quote]

Oui, c’etait bien ce que je disais, autant les educatifs et utilitaires, on sait ce que ca vaut (codage en 640x480 256 couleurs en Macromedia et Quicktime v1.5) pour Sacred ils pourraient se bouger le popotin. Car d’abord ca a été un jeu qui était buggé jusqu’à la moelle pendant plus de 18 mois, et 1 an plus tard, il n’est pas compatible avec le nouvel OS.

Ca donne moyen confiance pour Sacred 2.

oui enfin c’est facile de rejeter la faute aux développeurs, mais quand MS code Vista, ils connaissent déjà tous ces softs et ça me semble être un minimum que d’assurer la rétrocompatibilité. mais bon on a déjà eu le délire avec les jeux DOS sous 9x, les 9x sous XP, etc…
je trouve juste dommage de se dire qu’on est forcément condamnés à ne plus pouvoir utiliser ses vieux softs.

J’avais pas releve la premiere annerie mais la deuxiemme couche, c’est legerement abusé de venir donner des lecons sur ce sujet particulier…

Vu le nombre de hacks et bidouille deja present pour assurer la retro compatibilite avec des softs qui utilisent les API de maniere non documentee et pas du tout normale, c’est deja un enorme effort d’essayer de faire marcher les principaux softs y compris ceux codes avec deux pieds gauches (et dans le jeu video…) sans aller chercher dans les trucs pas fondamentaux de ce genre… Ce qui me fais sourire c’est qu’avec ce genre de reaction a l’emporte piece tu serais a en pas douter le premier a dire “bah si ils ont explicitement ignoré la doc et la maniere de faire, on les emmerde” si t’etais celui qui ecrit l’API… et tu te prendrais des remarque pareil parceque c’est pas comme ca que qui que ce soit pense pour avoir une tres bonne retrocompat comme c’est le cas aujourd’hui. Est ce qu’elle est parfaite? Certainement pas, mais suffit d’avoir code des API pendant 6 mois pour savoir que exiger que ca soit parfait tient de l’usage de stupefiant.

“Ils connaissent tous les softs” … bah non. Ils connaissent pas tous les softs, ni toutes les configs hardware avec tous les drivers et tous les usages a la porc d’API dans toutes les langues… Faire marcher les trucs comme c’est cense c’est deja bien assez delirant sans avoir a supporter ceux qui font pas les choses comme prevu. Je te conseille la lecture de “The old new thing” tu seras deja plus que surpris de ce qui est deja fait pour faire marcher certaines choses completements folles… Vu la surface couverte des API, et le nombre de possibilites, 150 ans avec 20 fois plus d’ingenieurs y suffiraient pas. Et chaque bidouille pour faire tourner un truc fais a la porc c’est un handicap pour tous ceux qui font les choses proprement…

Des bidouilles et des hacks pour faire marcher les softs ils vont en rajouter, t’inquiete… y en aura plein le SP1… Etonnament je pense pas que Sacred soit super haut sur la liste des priorites, doit bien y avoir deux trois softs fait par des consultants en COBOL il y a 15 ans dont plus personne a le code source qui sont “mission critical” pour quelques dizaines de milliers d’employes qui doivent peut etre passer avant… alors les generalites toutes faites du genre “on est condamne a plus pouvoir utiliser ses vieux softs” pour un jeu tellement supporté qu’ils sont meme pas fichu de faire marcher leur site web (pris a l’instant si je me trompe pas de site)… quelque part ca me surprendrait pas qu’ils aient completement ignoré les nombreux mois de beta…

Faut redescendre sur terre deux secondes des fois avant de donner des lecons sur sur ce qui est “du delire”…

Oui enfin c’est surtout que pour un joueur, tourner exclusivement sous Vista relève de l’inconscience. On sait bien que certains programmes ne vont plus fonctionner, c’était déjà le cas entre 98 SE et XP. Et comme dit Glop, Crosoft peut pas assurer la rétrocompatibilité sur TOUS les logicielsq existants ! Donc un double boot XP/Vista et on en parle plus non ? B)

attention à ne pas se méprendre sur la direction de ma colère
je me doute, dans la mesure des mes capacités, que Microsoft fait ce qu’il peut pour assurer cette fameuse rétrocompatibilité et que les dévs des applications tierces ne respectent pas toujours les règles qui permettent à l’avenir de l’assurer.

mais je parle d’un point de vue totalement néophyte, parce que moi oui je sais qu’il existe des moyens détournés de faire fonctionner ces jeux sous Vista, ou encore un vieux jeu DOS sous XP, mais je me considère comme un utilisateur relativement au courant (je me monte mes PC moi-même depuis une quinzaine d’années) mais sincèrement, même si dans mon entourage proche je suis un dieu de l’informatique, je me rends bien compte qu’au milieu de la zone je suis un n00b de la pire espèce. ce qui montre bien, à mon sens, le gouffre qui sépare quelqu’un comme toi (Glop) du commun des mortels qui achète naïvement son Sacred à 20€ qu’il pense pouvoir faire tourner sur son bôôôô PC tout neuf sous Vista et qui constate amèrement qu’il n’en est rien pour des raisons qui lui échappent totalement (et qui a priori ne l’intéresse pas du tout). c’est juste cet état de fait que je trouve exaspérant et qui est inhérent à l’informatique.
Le néophyte, l’utilisateur lambda, non seulement il ne comprend rien à tout ça mais surtout il s’en contrefout, lui.

Je me plaçais du côté purement consommateur qui n’est pas censé se soucier de ces choses, il ne verra pas pourquoi ça ne fonctionne pas et se plaindra, à juste titre. après à qui la cause, MS ou les dévs de l’application, pour la plupart des gens c’est bonnet blanc et blanc bonnet.

Bizarre, parce que moi, Sacred marche sous Vista. Bon avec quelques problèmes de performances, mais pas de quoi fouetter un chat.

Il faut surtout pas appliquer le dernier patch qui fait foirer la protection CD…

Enfin, c’est comme ça que je l’ai fait fonctionner.

C’est ptete con, mais ça serait pas possible de lancer les vieux soft dans une sorte de machine virtuelle à la virtual PC ?

D’un autre coté , le néophyte , il sait quand même lire et il peut regarder la liste des windows compatible avec ce qu’il achète.
la méconnaissance du monde de l’informatique n’est pas là non plus pour justifier la fainéantise de l’acheteur ( enfin du moins celui qui a dans ton exemple aurait acheté le jeu alors qu’il avait vista , hein oevesque ^^).

[quote=“BloodAngel, post:14, topic: 45638”]D’un autre coté , le néophyte , il sait quand même lire et il peut regarder la liste des windows compatible avec ce qu’il achète.
la méconnaissance du monde de l’informatique n’est pas là non plus pour justifier la fainéantise de l’acheteur ( enfin du moins celui qui a dans ton exemple aurait acheté le jeu alors qu’il avait vista , hein oevesque ^^).[/quote]
bah en même temps, un jeu qui est sorti avant Vista ne peut pas avoir écrit dessus compatible Vista (ou même incompatible Vista) par définition.
et le bon sens veut quand même que si ça marche sur un PC d’il y a 3 ans, ça doit marcher sur un PC d’aujourd’hui. ce n’est pas une question de fainéantise, ça semble a priori logique.

[quote=« Ghadzoeux, post:15, topic: 45638 »]bah en même temps, un jeu qui est sorti avant Vista ne peut pas avoir écrit dessus compatible Vista (ou même incompatible Vista) par définition.
et le bon sens veut quand même que si ça marche sur un PC d’il y a 3 ans, ça doit marcher sur un PC d’aujourd’hui. ce n’est pas une question de fainéantise, ça semble a priori logique.[/quote]

Oui, hein, tout ces débats pour ma pomme :wink:

Oui, quand j’ai acheté ce jeu Vista n’etait pas sorti, entre temps mon ordi a cramé, et j’ai du changé et passé à Vista.
Malheureusement pour moi ca ne fonctionne plus, bon tant pis, il retournera vivre chez Priceminister.

MAIS Pour recentrer le débat : Mad-Bhaal, quelle version de Sacred as tu ? (apparemment, il y a en a une tripotée (Normal, Plus, Gold, Underworld, Director’s Cut B) )

Oui…je sais B) : j’ai la première version de Sacred Plus qui est sortie dans le commerce, celle qui est sur 2 cd.

Bah pourquoi tu réinstalles pas XP à la place de Vista alors ? Ou bien en dualboot ? J’imagine que ton précédent pc avait bien un OS non ?

Oui et non, deja ca me saoule d’avoir un dual Boot. et deuxiemement, les OS tous seul je les ai pas, ils sont encapsulés dans le package fourre-tout fourni par Acer, Asus, ou Dell.
Et de toutes facons c’est des windows “taggés” au matos d’origine donc, meme en cas de crash disque dur, il faut racheter le MEME disque dur (testé chez Packard Bell)

Sinon, je suis quand meme étonné car Mad-Bahl a la “meme” version que moi, c’est à dire une sacred plus.

De toutes facons,j’ai Baldur’s Gate II à faire (oui je suis tres tres tres en retard sur les jeux). J’vais vérifier si il s’installe.

Tu as essayé sans l’avoir patché donc et ça ne fonctionne pas. Bizarre. Je sais par contre que Sacred est protégé par Starforce. Tu as appliqué le patch qui va bien, c’est à dire celui ci ?