De l'art de désactiver le reboot automatique de ce $&#@! de Windows 10 suite à un update

Après avoir eu un reboot durant la nuit alors que mon ordi tournait avec pas mal de softs ouverts et avoir lu les déboires de @Cafeine sur Twitter avec une expérience similaire j’ai commencé à chercher comment désactiver cette “feature”.

Comme il n’y a rien dans l’UI (cette dernière ne propose que de faire l’update plus tard quand l’ordi est inutilisé), il faut en fait se tourner vers le “Group Policy Editor”. Problème: il n’est dispo que dans Windows Pro.
La bonne nouvelle est qu’on peut l’installer soi-même. Petit tuto:

  • Téléchargez le Group Policy Editor ici: http://drudger.deviantart.com/art/Add-GPEDIT-msc-215792914 (je vous mets une copie ci-dessous)
    add_gpedit_msc_by_jwils876-d3kh6vm.zip (855.2 KB)
  • Installez le soft.
  • Si vous êtes en 64bits il vous faudra ensuite aller dans C:\Windows\SysWOW64 et copier les répertoires GroupPolicy et GroupPolicyUsers ainsi que le fichier gpedit.msc dans C:\Windows\System32
  • Lancez l’editeur en faisant Windows + R, tapez gpedit.msc et faites [Entrée]
  • Naviguez vers “Computer Configuration” / “Administrative Templates” /" Windows Components" / “Windows Update
  • Localisez la clé “No auto-restart with logged on users for scheduled automatic updates installations
  • Double-cliquez et sélectionnez “Enabled”
  • Voilà, (en théorie) plus de reboot sauvage. On verra au prochain Windows Update si ca marche…

4 « J'aime »

Bien vu.
Merci :slight_smile:

Testé il y a mois mois. Ca marche pas. Ma machine reboote toujours quand ca lui chante durant la nuit.

Note: This policy applies only when Automatic Updates is configured to perform scheduled installations of updates. If the “Configure Automatic Updates” policy is disabled, this policy has no effect.

Pour la prochaine fois, j’ai donc modifié ‘Configure Automatic Updates’, en mettant l’option 3 (Auto download and notify for install). On verra bien.

Ah ça répond à mon autre interrogation, qui était de demander avant de télécharger. Il y avait une solution qui demandait gpedit, du coup j’ai pu l’installer, on verra ce que ça donne.
Merci !

Yep, je confirme que ça ne marche pas, je viens de voir que j’avais déjà fait chez moi c’est local policy… et mon PC continue de rebooter comme un connard quand ça lui chante pour appliquer les updates.

Pareil, il m’a fait le coup récemment avec tout un tas de trucs ouverts, c’est horripilant.
Si quelqu’un trouve une solution pérenne je prends tout de suite.

J’ai le même grief concernant le download des updates. Je n’ai pas une bande passante mirobolante, alors que Windows la squatte quand ça lui chante commence à me courir aussi…

1 « J'aime »

C’est des petites choses comme ça qui, petit à petit, me font lâcher cet OS.
C’est lassant, mais lassant à la longue …

1 « J'aime »

et shutdown -a ?
/troll

(qui se souvient de ce putain de virus qui te forcait a connaitre cette commande par coeur parce que pendant un moment tout les pc rebootait en boucle avec une commande reseau sous windows ? )

1 « J'aime »

Pour contourner en partie le problème je met que mes heures d’activité, donc de non reboot, sont entre midi et minuit. On ne peut pas mettre plus de 12h comme s’ils avaient pensé aux petits malins.

Peut-être qu’il faut trouver dans la base de registre où modifier cette plage horaire au delà ?

Et pour éviter la mise-à-jour qui met des plombes, pile au moment où on a besoin d’éteindre l’ordi rapidement, quand je vois qu’il y a une mise-à-jour à installer je me mets en veille prolongée.

Et sinon avec un SSD? Le reboot prendra 40 secondes à tout casser

Le problème n’est sans doute pas le temps de redémarrage, mais le fait que des programmes étaient en cours d’activité.

Mais comment je love mon W8.1 :heart_eyes:

Le plus étonnant c’est que parfois quand je veux éteindre ou redémarrer, il reste «bloqué» parce qu’il me demande de confirmer la fermeture d’une ou l’autre applications. Du coup quand il redémarre pour une mise à jour il ne vous demande pas de confirmer?

J’ai un SSD sur mon portable, le reboot est effectivement très rapide. Ce qui est lent c’est ce qu’il fait avant et après le reboot.

Le nombre de pc de proches qu’il a fallu bricoler en monde sprint…

Non content de redémarrer sans mon accord dès qu’il installe une update, je me suis rendu compte que par défaut Windows distribue ses updates en P2P depuis mon PC:

Je commence doucement à regretter Seven.
Cette perte de contrôle de ce que fait mon OS commence à m’horripiler.

J’ai remarqué ça aussi cet après-midi. Je l’ai désactivé.

Quelqu’un a testé le Step 2 décrit ici : https://superuser.com/questions/973009/conclusively-stop-wake-timers-from-waking-windows-10-desktop/973029 ?

Bon, ca n’a pas marché. Mon ordi a rebooté cette nuit :frowning:

Tu avais bien configuré la deuxieme option comme je l’avais signalé plus haut ?

http://forum.geekzone.fr/t/de-lart-de-desactiver-le-reboot-automatique-de-ce-de-windows-10-suite-a-un-update/58838/4?u=xmichelo

Parce que chez moi, j’ai eu un pop-up qui m’informait de la dispo d’une MAJ. Donc je pars du principe que ca a marché.