Ecrans bleus fréquents = Kernel Power 41

Bon, c’était trop beau.
Avec mon nouveau PC, j’expérimente depuis quelques jours des BSOD avec l’intitulé Kernel Power 41.
C’est arrivé de manière inopinée à chaque fois, une fois j’étais en train de surfer sur le net, ce matin j’étais dans mon salon en train de streamer un film de vacances depuis Plex. Pas un usage particulièrement intensif.
J’ai creusé un peu le net et apparemment ça semble être une erreur plutôt difficile à diagnostiquer.
Première piste, il semble recommandé de désactiver le démarrage rapide de Windows, ce que j’ai fait mais il faudra attendre quelques jours pour voir si les effets sont là.

Pour l’instant, l’observateur d’évènements me rapporte l’erreur 4 fois (23/01, 27/01, 3/02 et aujourd’hui 7/02), je ne me souviens pourtant n’y avoir assisté que 2 fois (or ça tombe sur des jours/heures où j’étais soit sur mon PC, soit à côté en train d’écouter de la musique dessus).

J’ai pensé un instant que ça pouvait venir du changement de cg (qui nécessite des connecteurs alim en plus par rapport à celle d’avant qui n’en avait pas besoin), mais je l’ai changée le 27/01, or l’erreur s’est déjà produite quelques jours avant.

Bref, je ne sais pas trop vers quoi me diriger.

edit : WhoCrashed me donne ça :

The DPC watchdog detected a prolonged run time at an IRQL of DISPATCH_LEVEL or above. This could be caused by either a non-responding driver or non-responding hardware. This bug check can also occur because of overheated CPUs (thermal issue).
The crash took place in the Windows kernel. Possibly this problem is caused by another driver that cannot be identified at this time.

edit 2 : en fait les BSOD commencent le 23/01, or j’ai reçu le PC le 21 et je l’ai mis en service le même jour. Donc en gros, ça me le fait depuis le premier jour si je résume :pensive:

Question sur une évidence vu le message que tu cites : tu as regardé si le CPU ne surchauffait pas anormalement ?

Oui, je suis allé regarder. Les différents outils (openhardware monitor et Ryzen Master) me donnent un 30-32°C en utilisation, j’ai vu un pic à 55°C ingame. Rien de délirant il me semble.

Tu as vu ça avec la première réponse : Disable Runtime Broker to fix high CPU and memory usage ?

Tu peux nous mettre le rapport complet de WhoCrashed ?

Ton nouveau PC il y a que des composants neuf ou il y a de la recup ?

On Sun 07/02/2021 09:03:33 your computer crashed or a problem was reported
crash dump file: C:\Windows\Minidump\020721-11453-01.dmp
This was probably caused by the following module: ntoskrnl.exe (nt+0x244567)
Bugcheck code: 0x133 (0x0, 0x501, 0x500, 0xFFFFF807268FB320)
Error: DPC_WATCHDOG_VIOLATION
file path: C:\Windows\system32\ntoskrnl.exe
product: [Microsoft® Windows® Operating System](http://www.google.com/search?q=Microsoft® Windows® Operating System)
company: [Microsoft Corporation](http://www.google.com/search?q=Microsoft Corporation)
description: NT Kernel & System
Bug check description: The DPC watchdog detected a prolonged run time at an IRQL of DISPATCH_LEVEL or above. This could be caused by either a non-responding driver or non-responding hardware. This bug check can also occur because of overheated CPUs (thermal issue).
The crash took place in the Windows kernel. Possibly this problem is caused by another driver that cannot be identified at this time.

On Sun 07/02/2021 09:03:33 your computer crashed or a problem was reported
crash dump file: C:\Windows\MEMORY.DMP
This was probably caused by the following module: pshed.dll (pshed!pshedbugchecksystem+0x10)
Bugcheck code: 0x133 (0x0, 0x501, 0x500, 0xFFFFF807268FB320)
Error: DPC_WATCHDOG_VIOLATION
file path: C:\Windows\system32\pshed.dll
product: [Système d’exploitation Microsoft® Windows®](http://www.google.com/search?q=Système d’exploitation Microsoft® Windows®)
company: [Microsoft Corporation](http://www.google.com/search?q=Microsoft Corporation)
description: Pilote d’erreurs matérielles spécifiques à une plateforme
Bug check description: The DPC watchdog detected a prolonged run time at an IRQL of DISPATCH_LEVEL or above. This could be caused by either a non-responding driver or non-responding hardware. This bug check can also occur because of overheated CPUs (thermal issue).
The crash took place in a Microsoft module. The description of the module may give a hint about a non responding device in the system.

@SirAkuse J’ai un ancien HDD et la carte graphique rachetée à @Aedeser (et au départ c’était mon ancienne cg déplacée du PC précédent)

Je ne me souviens plus si c’était toi qui avait des bluescreen à répétition (sur ton ancien PC du coup) ? Si c’est bien le cas, je dégagerais le HDD.

Nope, c’est pas moi :sweat_smile:

1 « J'aime »

Arf, dommage… Mais du coup j’essaierais de virer le HDD quand même. J’ai eu le cas récemment sur un PC un peu ancien. Un des deux DD en raid1 qui avait des vapeurs et provoquait du coup des crashs plus ou moins random en activité.

Pour aller plus loin dans l’analyse il faudrait récupérer les dumps…

J’imagine que ta version de Windows est à jour des dernières mises à jour et drivers ?

Je pense que tu parlais de moi @SirAkuse

Je compatis, perso je pensais que c étais mieux en changeant la CM…mais non :sweat_smile:

1 « J'aime »

@El_Penguinno arf désolé d’apprendre que le changement de CM n’a rien changé.

Et oui, j ai tout tester, je pense que c est le proco qui a un soucis.

@Ghadzoeux y me semble que c est une bécane que tu as acheté montée, tu peux pas la tester juste avec ce qui t as été fourni?

C’est justement pour éviter ce genre de désagréments que j’ai opté pour une bécane montée dès le départ :pensive:
Dans un premier temps, je vais tester l’histoire du Runtime Broker.
Si ça revient, dans un deuxième temps je virerai le HDD classique, définitivement, j’arriverai à me débrouiller sans.

edit : j’ai fait les deux finalement. À voir si ça recommence.

Oublie pas de memtest aussi hein. C’est quand meme le truc facile a tester et qui arrive souvent et provoque beaucoup de trucs inexpliqués.

1 « J'aime »

Pas fait, je le note si ça doit se reproduire.

Dans le doute, fais en un au plus tot :slight_smile:

Je croise les doigts depuis samedi, j’ai viré le vieux HDD et fait la manip sur le Runtime Broker. Il n’y a rien eu depuis.

1 « J'aime »

Ouais, si ça revient, fais un memtest. J’avais le même souci, je dois avoir une ram qui déconne. Je les ai testées séparément sur chaque slot, tout va bien, mais les deux barrettes ensembles, c’est mort.

1 « J'aime »

Pour l’instant, ras depuis samedi. Il a rebooté cette nuit mais c’était une mise à jour Windows.

Bon ben reste a identifier le coupable entre le hdd et le param Windows (si la stab se confirme dans le temps). (Perso je parie sur le hdd)