TF2 et Ubuntu

Yop les geeks,

j’ai craqué et installé ubuntu sur mon monstre, j’ai reussi via playonlinux à lancer tf2 qui est lent, saccadé, moche et pleins d’artefacts.
les seuls drivers qui font marcher ma 8800 gt sur ce pc sont les 169.04 de nivdia. Je me remets à tout vos conseils pour optimiser le bon fonctionnement et à vos feedbacks

Qui joue sus ubuntu à tf2? et dans quelles conditions.

Hahahahaha. ahem. Haha.

Windows. Now.

Celon certains ça marche TRES bien sous ubuntu : http://forum.ubuntu-fr.org/viewtopic.php?id=171582
Sinon Google est ton ami.

google est mon ami, merci de ce conseil avisé, google m’a parlé de drivers propriétaires qui ne passent pas sur mon pc, google m’a parlé de playonlinux que j’ai installé…

Mais j’aime bien l’avis de geeks quand même.

[quote=“an0nyme, post:4, topic: 48952”]google est mon ami, merci de ce conseil avisé, google m’a parlé de drivers propriétaires qui ne passent pas sur mon pc, google m’a parlé de playonlinux que j’ai installé…

Mais j’aime bien l’avis de geeks quand même.[/quote]
Il te faut à tout pris les drivers propriétaires de NVidia pour espérer jouer dans de bonnes conditions, malheureusement NVidia ne communique pas les spécifications de ses cartes ce qui ne facilite pas le développement de drivers libres. Il n’y a aucune raison que le driver proprio ne s’installe pas sur ton PC, peux-tu nous donner plus de détails ?

Pour PlayOnLinux, c’est une application qui facilite l’installation de jeux sous Linux grâce à des scripts automatisés, si tu ne règle pas ton problème de driver, cette application ne te servira à rien.

As-tu jeté un œil à cette page : http://doc.ubuntu-fr.org/nvidia ?

Moi j’y joue depuis plusieurs mois sous Ubuntu.

Alors oui il te faut les driver proprio nVidia, donc si déjà là ça ne fonctionne pas chez toi, pas la peine d’essayer d’aller plus loin.

Sinon moi je l’utilise grâce à Wine (pas besoin de playonlinux, mais comme il est basé sur Wine ça ne devrait pas faire beaucoup de différence). La chose importante est de lancer le jeu en directx 8.1 (-dxlevel 81 comme option de démarrage du jeu) et virer tout ce qui est HDR et shaders. Résultat, le jeu n’est pas hyper beau, mais sur mon Athlon 3800 et la nVidia 6600 GTS, il est fluide et parfaitement jouable en 1680x1050.

Pour d’autres infos, regarder sur WineHQ.

[quote=“Longfield, post:6, topic: 48952”]Moi j’y joue depuis plusieurs mois sous Ubuntu.

Alors oui il te faut les driver proprio nVidia, donc si déjà là ça ne fonctionne pas chez toi, pas la peine d’essayer d’aller plus loin.

Sinon moi je l’utilise grâce à Wine (pas besoin de playonlinux, mais comme il est basé sur Wine ça ne devrait pas faire beaucoup de différence). La chose importante est de lancer le jeu en directx 8.1 (-dxlevel 81 comme option de démarrage du jeu) et virer tout ce qui est HDR et shaders. Résultat, le jeu n’est pas hyper beau, mais sur mon Athlon 3800 et la nVidia 6600 GTS, il est fluide et parfaitement jouable en 1680x1050.

Pour d’autres infos, regarder sur WineHQ.[/quote]

j’ai installé les Nvidia 169.04 des drivers propriétaires sortis pour la 8800. après le reste doit etre de la configuration, et notamment le coup de direct x je vais regarder çà merci pour l’info.

C’est certainement un soucis de configuration du logiciel informatique.

Je suis le seul que ça fait réagir ???

Pardon?

Mgskull : c’est sa retenue qu’ano a craqué, pas ubuntu ^^

Tu devrais regarder dans Synaptic la liste des paquet lié a Nvidia, perso j’avais trouvé les drivers kivonbien de la 8600 de mon laptop comme ça.

Ah oui pardon, faut dire que c’était pas explicite ^^ Désolé !

Quand j’installe les derniers proposés (en passant par administration gestion peripheriques) , a chaque restart il me propose le mode “low graphic” et refuse de prendre le driver qui est proposé par défaut sur Ubuntu. j’ai du installer a la main mon Driver 169.04 et le compiler …

T’as pas un nvidia-x-server-settings dans un truc genre systeme > admin ?

et sinon, en console,

[quote=“fser, post:15, topic: 48952”]T’as pas un nvidia-x-server-settings dans un truc genre systeme > admin ?

et sinon, en console,[/quote]

si c’est la commande pour verifier si le direct rendering est activé il l’est

Donc la commande pour lancer le jeu sous direct 8-1 j’fais comment?

-dxlevel81 (mais pourquoi ça passe pas en DX9 sous linux gépacompri)

je pige pas non plus c’est moche…

Alors ca, je crois que ca depend de la version de Wine.
Il y avait un probleme avec les versions anterieures de Wine qui faisait que TF2 en DX9 etait plein de bugs.
Les dernieres versions font tourner TF2 en DX9 sans probleme.
Pour installer les dernieres versions de Wine, tout est sur WineHQ la.

Je joue a TF2 sous Ubuntu depuis un bon moment et ca marche niquel chrome.
C’est plus lent que sous Windows, c’est sur, mais ca reste tres jouable.
Comme il a ete dit, il faut les drivers proprio Nvidia a tout prix et pas les libres.
Ca cause des fois des problemes avec la config de Xorg (quand ca te propose les “low graphic” c’est que le serveur X a pas reussis a demarrer avec la config courante).
Je suis pas un pro pour regler tout ca, va falloir ecumer les forums d’ubuntu, il y a toujours plein de solutions deja dispo la-bas, surement a base de modification de ton xorg.conf (situe dans /etc/X11/)

edit: il y a aussi souvent pas mal d’info concernant la configuration des jeux, les bugs connus et leur resolution possible sur la page de l’application sur WineHQ. Ici pour TF2.